Bug 19554 - gcc
Summary: gcc
Status: CLOSED DUPLICATE of bug 18803
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://www.gnu.org/software/gcc/gcc.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-22 20:03 UTC by Mike Richey
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-23 07:47:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Richey 2000-10-22 20:03:18 UTC
according to the GCC home page, 2.96 (the version included with rh7 is not
a stable release.  Quoted from the GCC Home Page:

GCC 2.96

October 6th, 2000

It has come to our attention that some GNU/Linux distributions are
currently shipping with ``GCC 2.96''.

We would like to point out that GCC 2.96 is not a formal GCC release nor
will there ever be such a release. Rather, GCC 2.96 has been the code- name
for our development branch that will eventually become GCC 3.0.

Current snapshots of GCC, and any version labeled 2.96, produce object
files that are not compatible with those produced by either GCC 2.95.2 or
the forthcoming GCC 3.0. Therefore, programs built with these snapshots
will not be compatible
with any official GCC release. Actually, C and Fortran code will probably
be compatible, but code in other languages, most notably C++ due to
incompatibilities in symbol encoding (``mangling''), the standard library
and the application binary
interface (ABI), is likely to fail in some way. Static linking against C++
libraries may make a binary more portable, at the cost of increasing file
size and memory use.

To avoid any confusion, we have bumped the version of our current
development branch to GCC 2.97.

Please note that both GCC 2.96 and 2.97 are development versions; we do not
recommend using them for production purposes. Binaries built using any
version of GCC 2.96 or 2.97 will not be portable to systems based on one of
our regular
releases.

If you encounter a bug in a compiler labeled 2.96, we suggest you contact
whoever supplied the compiler as we can not support 2.96 versions that were
not issued by the GCC team.

Please see http://gcc.gnu.org/snapshots.html if you want to use our latest
snapshots. We suggest you use 2.95.2 if you are uncertain.

The GCC Steering Committee


Why on earth would you include an incomplete version of GCC with RH7?????

Comment 1 Jakub Jelinek 2000-10-23 07:30:47 UTC
The wv part should be fixed in wv 0.6.2 (at least wv developers told me),
the gcc segfault (gcc should obviously not crash even on bad input) is fixed
in 2.96-57 (in rawhide) and above and will appear in the next gcc errata.

*** This bug has been marked as a duplicate of 19392 ***

Comment 2 Jakub Jelinek 2000-10-23 07:47:50 UTC
Oops, sorry, this was resolval for #19545 typed mistakenly into this ID.

Comment 3 Jakub Jelinek 2000-10-23 07:50:48 UTC

*** This bug has been marked as a duplicate of 18803 ***


Note You need to log in before you can comment on or make changes to this bug.