Bug 1955685 - [RFE][OSP 17] Deprecate legacy buses, device models not supported by q35
Summary: [RFE][OSP 17] Deprecate legacy buses, device models not supported by q35
Keywords:
Status: ASSIGNED
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Lee Yarwood
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 16:28 UTC by Stephen Finucane
Modified: 2021-05-12 04:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version: Xena


Attachments (Terms of Use)

Description Stephen Finucane 2021-04-30 16:28:31 UTC
Description of problem:

We are hoping to transition from the legacy, deprecated pc-i440fx (pc) machine type to the more modern pc-q35 (q35) machine type. The q35 machine type does not support a number of buses such as IDE along with devices like emulated floppy drives and device buses such as cirrus. This RFE tracks the deprecation of these buses and devices along with the provision of tooling to transition them to their more modern equivalents.


Note You need to log in before you can comment on or make changes to this bug.