Bug 1955823 - [Assisted Installer] PSI/Minikube Assisted installer deployments fail to deploy version 1.5.17
Summary: [Assisted Installer] PSI/Minikube Assisted installer deployments fail to depl...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: assisted-installer
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Ronnie Lazar
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-30 21:32 UTC by gharden
Modified: 2021-05-03 13:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 13:32:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description gharden 2021-04-30 21:32:40 UTC
Description of problem:
1. PSI deployment with stable-candidate tag fails because of postgres

Unable to attach or mount volumes: unmounted volumes=[postgredb], unattached volumes=[postgredb default-token-9bphb]: timed out waiting for the condition.

PSI deployment succeeds when stable tag is used, but deploys v1.5.14


2. Minikube deployment fails when tag v1.5.17 is used.

raise HTTPError(http_error_msg, response=self)\nrequests.exceptions.HTTPError: 404 Client Error: Not Found for url: https://api.github.com/repos/openshift-assisted/assisted-installer-deployment/contents/assisted-installer.yaml?ref=v1.5.17

Minikube deployment succeeds when stable tag is used, but deploys v1.5.14


Version-Release number of selected component (if applicable):
ui: 1.5.17

How reproducible:
100%


Steps to Reproduce:
1. Deploy Assisted installer on PSI using stable-candidate tag or deploy assisted installer on Minikube using stable or v1.5.17 tag

Actual results:
Deployment fails

Expected results:
Deployment succeeds 

Additional info:

Comment 1 Ronnie Lazar 2021-05-02 14:15:02 UTC
tag v1.5.17 is a UI version and not Assisted-install tag, so you can not deploy assisted-install using this tag

Can you paste the errors you get when deploying stable-candidate?

Comment 2 gharden 2021-05-03 13:32:22 UTC
Issue is resolved now. Closing


Note You need to log in before you can comment on or make changes to this bug.