Bug 195591 - The init scripts for the cluster components are broken
The init scripts for the cluster components are broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Abhijith Das
Cluster QE
:
: 196020 (view as bug list)
Depends On:
Blocks: 180259
  Show dependency treegraph
 
Reported: 2006-06-15 16:36 EDT by Kiersten (Kerri) Anderson
Modified: 2009-04-16 18:26 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0575
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 11:58:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiersten (Kerri) Anderson 2006-06-15 16:36:30 EDT
Description of problem:
The current init scripts in the source base have not been updated to reflect the
 changes in the infrastructure.  The cman script still trys to load kernel
modules that no longer exist.  There are no startup references to the new dlm
modules, no references for configfs, and nothing starts up groupd.  

Need to replace all of the current core infrastructure startup scripts with
probably a single one that does the following:

Loads the appropriate kernel modules
mount -t configfs none /sys/kernel/config
ccsd -X
cman_tool join
groupd
fenced
dlm_controld
gfs_controld

Also, need the appropriate stop command and status commands for the init scripts.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Abhijith Das 2006-06-20 14:38:03 EDT
*** Bug 196020 has been marked as a duplicate of this bug. ***
Comment 2 Abhijith Das 2006-06-28 16:56:44 EDT
Committed single init script to start up cluster called cman: Covers loading of
modules, starting ccsd, cman and fencing, and starting daemons(gfs_controld,
dlm_controld, fenced and groupd). Replaces ccsd, cman and fenced init scripts.
Comment 3 Robert Peterson 2006-07-28 14:08:47 EDT
The gfs script has a problem with its loop to unmount all gfs
mounts.  If you have a gfs2 file system mounted, it will loop
repeatedly, mistaking it for a gfs file system.
Comment 4 Abhijith Das 2006-08-04 15:46:35 EDT
changed awk regexp string to fix the problem in comment#3. Fix committed for gfs
and gfs2 init scripts in cvs HEAD.
Comment 6 Kiersten (Kerri) Anderson 2007-04-23 12:47:36 EDT
Fixing Product Name.  Cluster Suite was merged into Red Hat Enterpise Linux for
5.0.  In addition dlm, fence and ccs were merged into the cman package, so
bugzilla should reflect package name where those utilities are located.
Comment 8 RHEL Product and Program Management 2007-05-01 12:31:19 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 RHEL Product and Program Management 2007-05-01 12:31:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 errata-xmlrpc 2007-11-07 11:58:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0575.html

Note You need to log in before you can comment on or make changes to this bug.