Bug 1956112 - radeonsi_drv_video libva driver regression on HD 8790M Southern Islands
Summary: radeonsi_drv_video libva driver regression on HD 8790M Southern Islands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 34
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-02 20:01 UTC by Travis Juntara
Modified: 2021-05-03 21:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 21:10:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Travis Juntara 2021-05-02 20:01:09 UTC
Description of problem:
Loading LibVA in vainfo for HD 8790M in fails in both radeonsi and amdgpu under Fedora 34. Was working fine in Fedora 33. Tested on both Release repo version and Updates repo version.

Version-Release number of selected component (if applicable):
mesa-dri-drivers-21.0.2-1.fc34.x86_64
mesa-dri-drivers-21.0.3-2.fc34.x86_64

How reproducible:
Consistently reproducible on my hardware.

Steps to Reproduce:
1.LIBVA_DRIVER_NAME=radeonsi DRI_PRIME=1 vainfo

Actual results:
libva info: VA-API version 1.11.0
libva info: User environment variable requested driver 'radeonsi'
libva info: Trying to open /usr/lib64/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_11
kmsro: driver missing
libva error: /usr/lib64/dri/radeonsi_drv_video.so init failed
libva info: va_openDriver() returns 2
vaInitialize failed with error code 2 (resource allocation failed),exit

Expected results:
Should list Driver version and supported profile and entrypoints.

Additional info:
Intel i965 vainfo outputs fine and vaapi works fine:
➜  ~ vainfo
libva info: VA-API version 1.11.0
libva info: Trying to open /usr/lib64/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_11
libva error: /usr/lib64/dri/iHD_drv_video.so init failed
libva info: va_openDriver() returns 1
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_10
failed to open /usr/lib64/dri/hybrid_drv_video.so
Not using hybrid_drv_video.so
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.11 (libva 2.11.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Haswell Mobile - 2.4.1
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Simple            : VAEntrypointEncSlice
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileH264MultiviewHigh      : VAEntrypointVLD
      VAProfileH264MultiviewHigh      : VAEntrypointEncSlice
      VAProfileH264StereoHigh         : VAEntrypointVLD
      VAProfileH264StereoHigh         : VAEntrypointEncSlice
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
      VAProfileJPEGBaseline           : VAEntrypointVLD

neofetch output:

OS: Fedora release 34 (Thirty Four) x86_64 
Host: Dell Latitude E6540 00 
Kernel: 5.11.16-300.fc34.x86_64 
Uptime: 18 mins 
Packages: 3700 (rpm) 
Shell: zsh 5.8 
Resolution: 1920x1080 
DE: Plasma 5.21.4 
WM: kwin 
WM Theme: Breeze 
Theme: Breeze [Plasma], Adwaita [GTK2] 
Icons: breeze [Plasma], breeze [GTK2/3] 
Terminal: konsole 
CPU: Intel i5-4310M (4) @ 3.400GHz 
GPU: Intel 4th Gen Core Processor 
GPU: AMD ATI Radeon HD 8790M 
Memory: 3518MiB / 7849MiB

Comment 1 Travis Juntara 2021-05-03 21:00:58 UTC
Huh... only Wayland is affected, I just booted into X11 and, I'm not seeing this particular issue.

Comment 2 Travis Juntara 2021-05-03 21:10:09 UTC
I'm gonna close this out because I claimed this feature was working before, but I was in X11 mode KDE Plasma in F33, but when I upgraded to F34 I was defaulted to Wayland unknowingly.


Note You need to log in before you can comment on or make changes to this bug.