Bug 1956137 - SELinux is preventing tlp from 'map' accesses on the file /usr/bin/bash.
Summary: SELinux is preventing tlp from 'map' accesses on the file /usr/bin/bash.
Keywords:
Status: CLOSED DUPLICATE of bug 1954358
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:58855508a45d14c25bfef673f17...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 00:08 UTC by Alexander Scheel
Modified: 2021-05-03 17:29 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 17:29:32 UTC
Type: ---


Attachments (Terms of Use)

Description Alexander Scheel 2021-05-03 00:08:01 UTC
Description of problem:
Same as https://bugzilla.redhat.com/show_bug.cgi?id=1941445: 

Upgraded from F33->F34, touch /.autorelabel, closed laptop lid, came back, opened it back up and got a ton new alerts (~28 before, now at ~114!).
SELinux is preventing tlp from 'map' accesses on the file /usr/bin/bash.

*****  Plugin catchall_boolean (89.3 confidence) suggests   ******************

If you want to allow domain to can mmap files
Then you must tell SELinux about this by enabling the 'domain_can_mmap_files' boolean.

Do
setsebool -P domain_can_mmap_files 1

*****  Plugin catchall (11.6 confidence) suggests   **************************

If you believe that tlp should be allowed map access on the bash file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'tlp' --raw | audit2allow -M my-tlp
# semodule -X 300 -i my-tlp.pp

Additional Information:
Source Context                system_u:system_r:systemd_sleep_t:s0
Target Context                system_u:object_r:shell_exec_t:s0
Target Objects                /usr/bin/bash [ file ]
Source                        tlp
Source Path                   tlp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           bash-5.1.0-2.fc34.x86_64
SELinux Policy RPM            selinux-policy-targeted-34.3-1.fc34.noarch
Local Policy RPM              selinux-policy-targeted-34.3-1.fc34.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 5.11.16-300.fc34.x86_64 #1 SMP Wed
                              Apr 21 13:18:33 UTC 2021 x86_64 x86_64
Alert Count                   1
First Seen                    2021-05-02 20:01:03 EDT
Last Seen                     2021-05-02 20:01:03 EDT
Local ID                      3e01f93c-d55d-4c5e-945a-79a480b4f414

Raw Audit Messages
type=AVC msg=audit(1620000063.117:1337): avc:  denied  { map } for  pid=9800 comm="tlp" path="/usr/bin/bash" dev="dm-1" ino=1879337 scontext=system_u:system_r:systemd_sleep_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file permissive=1


Hash: tlp,systemd_sleep_t,shell_exec_t,file,map

Version-Release number of selected component:
selinux-policy-targeted-34.3-1.fc34.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.14.0
hashmarkername: setroubleshoot
kernel:         5.11.16-300.fc34.x86_64
type:           libreport

Comment 1 Zdenek Pytela 2021-05-03 17:29:32 UTC

*** This bug has been marked as a duplicate of bug 1954358 ***


Note You need to log in before you can comment on or make changes to this bug.