Bug 1956168 - Fedora upgrade gui in the software option is truncating long package names
Summary: Fedora upgrade gui in the software option is truncating long package names
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 33
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 06:42 UTC by jtougne
Modified: 2021-05-03 16:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-03 08:48:00 UTC
Type: Bug


Attachments (Terms of Use)
Error (17.41 KB, image/png)
2021-05-03 06:42 UTC, jtougne
no flags Details
This is the "upgrade" section I am referring to. The error appeared after clicking Download and then on "Update or Upgrade(forgot the exact name)" (78.75 KB, image/png)
2021-05-03 06:44 UTC, jtougne
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-software - issues 1240 0 None None None 2021-05-03 08:40:16 UTC

Description jtougne 2021-05-03 06:42:57 UTC
Created attachment 1778842 [details]
Error

Description of problem:

Hi,
Not entirely sure it's related to gnome-software...In the "software" section of Fedora 33 there was an upgrade banner allowing the user to upgrade to Fedora 34.

It scanned for installed packages and gave a warning when it found one package that will no longer be compatible with F34 and informed it will be removed.

The package name is truncated and I could not find a way to see its full name easily from the GUI.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Have a package with long name, that won't be compatible with F34
2. Run the software gui in F33, click on upgrade.
3. See the warning gui

Actual results:
It shows only part of the package name.

Expected results:
It should show the full package name, without restrictions.

Additional info:
FYI, there is some sort of cache at play because I uninstalled the package not compatible, and cleared the cache, installed the latest version of that package (which should be compatible with F34) and dnf clean all and went to software again. Click on redownload, and upgrade to F34: same error again. Then I simply rebooted and checked again: no more error.
That is why it's important that we see the full package name, so we are sure that it's not complaining anymore about the old package (that was removed by myself manually following that warning).

Comment 1 jtougne 2021-05-03 06:44:49 UTC
Created attachment 1778843 [details]
This is the "upgrade" section I am referring to. The error appeared after clicking Download and then on "Update or Upgrade(forgot the exact name)"

Comment 2 Milan Crha 2021-05-03 08:40:16 UTC
Thanks for a bug report. Do you know the exact package name and version, which can reproduce the error, please? It'll be easier for testing.

This is not Fedora specific, thus it should be fixed upstream. I opened [1] for it.

[1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1240

Comment 3 jtougne 2021-05-03 08:43:41 UTC
(In reply to Milan Crha from comment #2)
> Thanks for a bug report. Do you know the exact package name and version,
> which can reproduce the error, please? It'll be easier for testing.
> 
> This is not Fedora specific, thus it should be fixed upstream. I opened [1]
> for it.
> 
> [1] https://gitlab.gnome.org/GNOME/gnome-software/-/issues/1240

This one will trigger the message:
redhat-internal-NetworkManager-openvpn-profiles.noarch                                0.1-35.el7.csb

Cheers,

Comment 4 Milan Crha 2021-05-03 08:48:00 UTC
Thank you for a quick update, I'll try with it. I'm closing this bug in favour of the upstream bug.

Comment 5 Milan Crha 2021-05-03 16:27:39 UTC
Hrm, that package is gone from the build system and I've not been able to reproduce it with some of my hacks, but the idea is clear, thus I guess the upstream will come with a simple solution.


Note You need to log in before you can comment on or make changes to this bug.