Bug 1956243 - Can't install kernel-devel because of compat-openssl11
Summary: Can't install kernel-devel because of compat-openssl11
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: compat-openssl11
Version: 9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: ---
Assignee: Sahana Prasad
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-05-03 09:50 UTC by Martin Cermak
Modified: 2021-05-06 12:42 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-06 12:42:02 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Cermak 2021-05-03 09:50:53 UTC
I don't seem to be able top install kernel-devel because of anticipated packaging problem in openssl.  This is a log from aarch64, but I can reproduce on all the arches:


# yum install kernel-devel
Updating Subscription Management repositories.
Unable to read consumer identity

This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.

Last metadata expiration check: 0:06:15 ago on Mon 03 May 2021 05:39:26 AM EDT.
Error: 
 Problem: problem with installed package compat-openssl11-1:1.1.1k-1.el9.aarch64
  - package compat-openssl11-1:1.1.1k-1.el9.aarch64 conflicts with openssl-libs < 1:3.0 provided by openssl-libs-1:1.1.1j-1.el9.aarch64
  - package openssl-devel-1:1.1.1j-1.el9.aarch64 requires openssl-libs(aarch-64) = 1:1.1.1j-1.el9, but none of the providers can be installed
  - package kernel-devel-5.12.0-0.rc8.193.el9.aarch64 requires openssl-devel, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
#


Note You need to log in before you can comment on or make changes to this bug.