Bug 195661 - Wrong permissions on MonitoringConfig page
Wrong permissions on MonitoringConfig page
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan Newberry
Vlady Zlatkin
Depends On:
Blocks: 171832
  Show dependency treegraph
Reported: 2006-06-16 09:37 EDT by Ken Ganong
Modified: 2013-08-05 23:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-07-19 19:32:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-06-16 09:37:06 EDT
I have a user that is a Monitoring Admin, but not an org admin.
When I click on the monitoring main tab, I see a link for General Config in the
left navigation.  However, when I click on that link, I get a permission error.

From sitenav:   acl="show_monitoring()"
From struts:    value="user_role(org_admin); global_config(satellite)"/>

These two acls must agree.

Make a user.
Give that user Monitoring Admin, but not Org Admin Permissions.
Visit the top level Monitoring Nav Tab.

Expected Results:
Either General Config does appear and you can successfully visit the page
OR General Config does not appear and you get a permission error on this url:
Comment 1 Mike McCune 2006-06-19 20:20:59 EDT
move to ON_QA 
Comment 2 Mike McCune 2006-06-19 20:26:14 EDT
really move to ON_QA !!!!
Comment 3 Vlady Zlatkin 2006-06-20 10:52:45 EDT
something failed with the permissions on /rhn/admin/config/MonitoringConfig.do

install satellite
create new user
click on satellite tools
click on satellite configuration
click on monitoring

I should get a page telling me to enable Monitoring in the general tab

Since this is an issue that goes with the title of this bug, I am adding it to
this bug as opposed to filling a new one.  
Comment 4 Vlady Zlatkin 2006-06-20 10:56:10 EDT
The originial testplan works.

as a monitoring admin I can make changes to the monitoring config page
as a normal user I get a 404 when trying to access the config page directly
Comment 5 Ryan Newberry 2006-06-21 13:54:20 EDT
Fixed in 420, 415, and 410 as of revision 96123

A monitoring admin or an org admin should be able to see and access the
Monitoring config tabs now if monitoring is enabled. If monitoring is disabled
the monitoring config UI tabs should now show. Normal users should get a
permission denied ALWAYS if they try to go there directly.
Comment 6 Ryan Newberry 2006-06-23 09:27:05 EDT
Moving my bugs to ON_QA
Comment 7 Vlady Zlatkin 2006-06-23 16:13:34 EDT
verified on -118 iso
Comment 8 Beth Nackashi 2006-07-19 19:32:52 EDT
closing - currentrelease

Note You need to log in before you can comment on or make changes to this bug.