Bug 195661 - Wrong permissions on MonitoringConfig page
Summary: Wrong permissions on MonitoringConfig page
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn410
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ryan Newberry
QA Contact: Vlady Zlatkin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 171832
TreeView+ depends on / blocked
 
Reported: 2006-06-16 13:37 UTC by Ken Ganong
Modified: 2013-08-06 03:14 UTC (History)
2 users (show)

Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 23:32:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken Ganong 2006-06-16 13:37:06 UTC
I have a user that is a Monitoring Admin, but not an org admin.
When I click on the monitoring main tab, I see a link for General Config in the
left navigation.  However, when I click on that link, I get a permission error.

From sitenav:   acl="show_monitoring()"
From struts:    value="user_role(org_admin); global_config(satellite)"/>

These two acls must agree.


TEST PLAN:
Make a user.
Give that user Monitoring Admin, but not Org Admin Permissions.
Visit the top level Monitoring Nav Tab.

Expected Results:
Either General Config does appear and you can successfully visit the page
OR General Config does not appear and you get a permission error on this url:
/rhn/admin/config/MonitoringConfig.do

Comment 1 Mike McCune 2006-06-20 00:20:59 UTC
move to ON_QA 

Comment 2 Mike McCune 2006-06-20 00:26:14 UTC
really move to ON_QA !!!!

Comment 3 Vlady Zlatkin 2006-06-20 14:52:45 UTC
something failed with the permissions on /rhn/admin/config/MonitoringConfig.do

steps:
install satellite
create new user
click on satellite tools
click on satellite configuration
click on monitoring
404

I should get a page telling me to enable Monitoring in the general tab

Since this is an issue that goes with the title of this bug, I am adding it to
this bug as opposed to filling a new one.  

Comment 4 Vlady Zlatkin 2006-06-20 14:56:10 UTC
The originial testplan works.

as a monitoring admin I can make changes to the monitoring config page
as a normal user I get a 404 when trying to access the config page directly

Comment 5 Ryan Newberry 2006-06-21 17:54:20 UTC
Fixed in 420, 415, and 410 as of revision 96123

A monitoring admin or an org admin should be able to see and access the
Monitoring config tabs now if monitoring is enabled. If monitoring is disabled
the monitoring config UI tabs should now show. Normal users should get a
permission denied ALWAYS if they try to go there directly.

Comment 6 Ryan Newberry 2006-06-23 13:27:05 UTC
Moving my bugs to ON_QA

Comment 7 Vlady Zlatkin 2006-06-23 20:13:34 UTC
verified on -118 iso

Comment 8 Beth Nackashi 2006-07-19 23:32:52 UTC
closing - currentrelease


Note You need to log in before you can comment on or make changes to this bug.