Bug 195673 - JDBC problems on Probe Create page
JDBC problems on Probe Create page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn410
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Steve Salevan
:
Depends On:
Blocks: 171832
  Show dependency treegraph
 
Reported: 2006-06-16 10:36 EDT by Ken Ganong
Modified: 2007-04-18 13:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn410
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-19 21:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tomcat's log file for the problem (93.04 KB, text/plain)
2006-06-16 10:36 EDT, Ken Ganong
no flags Details
traceback (8.66 KB, application/octet-stream)
2006-06-30 16:08 EDT, Vlady Zlatkin
no flags Details

  None (edit)
Description Ken Ganong 2006-06-16 10:36:31 EDT
What I did:
logged in to frogger.rhndev as monitoring admin
Clicked on Monitoring upper level tab.
Clicked Probe Suites and created a probe suite.
After creating probe suite, I am brought to a a probe list and I clicked on
create new probe.
Internal Server Error.

Vlad created a probe on his satellite right in front of me, so this page can
work and the state of the satellite clearly has some bearing on the bug.
However, I can create a probe suite and users, so the problem is decently localized.

There is a traceback attached
Comment 1 Ken Ganong 2006-06-16 10:36:32 EDT
Created attachment 131044 [details]
Tomcat's log file for the problem
Comment 2 Mike McCune 2006-06-20 19:27:04 EDT
This happened on frogger which was created from an ISO version 99 (or earlier).
 There seemed to be a schema issue with these older ISOs, which is no longer
reproduceable.

I tried this on a newly installed sat and also verified in

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=193719

that this no longer occurs in ISOs versioned 100+





Comment 3 Mike McCune 2006-06-20 19:31:42 EDT
TESTPLAN:

0) Install:

rhn-satellite-4.1.0-114-redhat-linux-as-i386-4-embedded-oracle.iso

or later ISO

1) Enable Monitoring from the General Config page
2) Enable Monitoring Scout from Monitoring tab
3) Clicked on Monitoring upper level tab.
4) Clicked Probe Suites and created a probe suite.
5) After creating probe suite, I am brought to a a probe list and I clicked on
create new probe.
6) verify that you can create a probe without error.
Comment 4 Vlady Zlatkin 2006-06-21 10:51:14 EDT
verified 
Comment 5 Mike McCune 2006-06-30 16:04:39 EDT
this is happening again on rlx-2-18
Comment 6 Vlady Zlatkin 2006-06-30 16:08:36 EDT
Created attachment 131830 [details]
traceback

as mike mentioned this is happening again.  I was able to create some probes,
but at some point i started to get ISEs

for a specific example follow this:

click on
https://rlx-2-18.rhndev.redhat.com/rhn/monitoring/config/ProbeSuiteListProbes.do?suite_id=3
click to create new probe
Comment 7 Mike McCune 2006-07-05 19:48:56 EDT
Changed the way we cache some of the data wrt the Monitoring Probe information. 

Retest with above plan.
Comment 8 Mike McCune 2006-07-06 19:29:48 EDT
This bug is available in the 4.1.0-128 ISO.  Moving to ON_QA.  Don't try and
test it on WEBQA yet or on an older ISO.
Comment 9 Steve Salevan 2006-07-07 10:05:48 EDT
QA Contact -> ssalevan
Comment 10 Steve Salevan 2006-07-07 11:49:02 EDT
I've tested this on a fresh 410-128 Satellite and have verified that, after
creating 25 probes, I did not receive an ISE.  Since this seems to be fixed, I'm
moving it to VERIFIED.
Comment 11 Beth Nackashi 2006-07-19 20:12:47 EDT
closing - currentrelease
Comment 12 Beth Nackashi 2006-07-19 21:46:57 EDT
closing - current release

Note You need to log in before you can comment on or make changes to this bug.