Bug 195708 - synergyc: error while loading shared libraries: libstdc++.so.5
synergyc: error while loading shared libraries: libstdc++.so.5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: synergy (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 14:19 EDT by Mark Sobell
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 11:37:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Sobell 2006-06-16 14:19:23 EDT
Description of problem:
synergyc will not run

Version-Release number of selected component (if applicable):
synergy.i386 0:1.3.1-1.fc5 (from extras)

How reproducible:
always

Steps to Reproduce:
1. Use yum to install synergy
2. run synergyc
3.
  
Actual results:
synergyc: error while loading shared libraries: libstdc++.so.5: cannot open
shared object file: No such file or directory


Expected results:
should run w/o error

Additional info:
Comment 1 Jesse Keating 2006-06-16 14:23:11 EDT
Most likely the synergy package is missing a Requires: on this library.
Comment 2 Mark Sobell 2006-06-16 14:57:21 EDT
FC5 has /usr/lib/libstdc++.so.6 installed.

The rpm posted on sourceforge
(http://sourceforge.net/project/showfiles.php?group_id=59275&package_id=58013)
fails with

rpm -Uvh *rpm
error: Failed dependencies:
        libstdc++-libc6.2-2.so.3 is needed by synergy-1.3.1-1.i386
Comment 3 Jesse Keating 2006-06-16 15:19:09 EDT
You need compat-libstdc++-296 installed, as that is the package that provides
/usr/lib/libstdc++-libc6.2-2.so.3

The upstream package from sourceforge would need a Requires:
libstdc++-libc6.2-2.so.3 or some such.
Comment 4 Mark Sobell 2006-06-16 17:32:03 EDT
After playing with this for a while, it turns out I needed to install

compat-libstdc++-33.i386

Then synergyc worked.

Thanks Jesse.
Comment 5 Matthias Saou 2006-06-22 05:08:24 EDT
I can't reproduce here on FC5 i386 :

$ ls /usr/lib/libstdc++*
/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so   /usr/lib/libstdc++-libc6.2-2.so.3
/usr/lib/libstdc++-3-libc6.2-2-2.10.0.so  /usr/lib/libstdc++.so.6
/usr/lib/libstdc++-libc6.1-1.so.2         /usr/lib/libstdc++.so.6.0.8

[dude@python2 dude]$ sudo rpm -Uvh synergy-1.3.1-1.fc5.i386.rpm
Preparing...                ########################################### [100%]
   1:synergy                ########################################### [100%]
[dude@python2 dude]$ synergyc
synergyc: a server address or name is required
Try `synergyc --help' for more information.

Can you please try to run :
rpm -q --requires synergy | grep libstd
(should return :
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4))
Comment 6 Mark Sobell 2006-06-22 11:00:11 EDT
$ rpm -q --requires synergy | grep libstd
libstdc++.so.6
libstdc++.so.6(CXXABI_1.3)
libstdc++.so.6(GLIBCXX_3.4)
Comment 7 Matthias Saou 2006-06-22 11:17:47 EDT
Hmmm... could you try "synergyc --version" and "which synergyc"... this seems
like the typical case where you might have an older synergyc binary lying around
which gets found first in your $PATH...
Comment 8 Mark Sobell 2006-06-22 11:34:12 EDT
$ whereis synergyc
synergyc: /usr/bin/synergyc /usr/local/bin/synergyc

Thanks Matthias -- sorry for the trouble.
Comment 9 Matthias Saou 2006-06-22 11:37:07 EDT
No problem :-)

Note You need to log in before you can comment on or make changes to this bug.