Bug 195717 - Cancel Kickstart link shows up & Page refeshes even after KS completed
Cancel Kickstart link shows up & Page refeshes even after KS completed
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn420
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jesus M. Rodriguez
Beth Nackashi
https://rhn.webqa.redhat.com/rhn/syst...
:
: 195718 (view as bug list)
Depends On:
Blocks: 198508
  Show dependency treegraph
 
Reported: 2006-06-16 14:51 EDT by Partha Aji
Modified: 2007-04-18 13:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-11 18:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KickStartStatus file - step 7 (280.88 KB, image/png)
2006-06-16 14:51 EDT, Partha Aji
no flags Details

  None (edit)
Description Partha Aji 2006-06-16 14:51:16 EDT
Created attachment 131070 [details]
KickStartStatus file - step 7
Comment 1 Partha Aji 2006-06-16 14:51:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Note you need to login as testplan_ks14/redhat to view the  actual page in the 
bug url...

Issue:
Cancel Kickstart link shows up & Page refeshes continue even after the
Description states Kickstart completed

Steps to Reproduce:
Pre reqs: User X on  Hosted having access to a bunch of Kickstartable systems

1. Login on hosted as X
2. Systems -> Select a system  (to goto System Details)
3. Edit Properties -> Check Provisioning -> Update (to return to System Details)
4. On System Details -> Provisioning -> Schedule Kick start
5. On the SessionStatus.do page, notice 
"Description:  | Something like Session created  but not started ......"
"Cancel Kickstart?  |	 Cancel Kickstart"

6) ssh to host system & rhn_check  (make sure you change the useGPG=0 in
/etc/sysconfig/rhn/up2date).
7) After 10 min check sessionStatus.do again  .. notice that it says

"Description:  | 	Kickstart complete."
"Cancel Kickstart?  |	 Cancel Kickstart"

It impossible to cancel a kickstart after "Reboot System" has been done... 
It also make NO sense refreshing the page after "Kickstart Complete", becuase
there is NO data that'd change on the page.


Actual results:


Expected results:


Additional info:
Comment 2 Mike McCune 2007-04-11 18:32:28 EDT
*** Bug 195718 has been marked as a duplicate of this bug. ***
Comment 3 Mike McCune 2007-04-11 18:33:00 EDT
closing due to lack of activity and priority.

Note You need to log in before you can comment on or make changes to this bug.