Bug 195768 - Autofs requires version 5, which is not in the kernel
Autofs requires version 5, which is not in the kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 11:37 EDT by david.hagood
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 22:28:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.hagood 2006-06-17 11:37:41 EDT
Description of problem:
The autofs daemon requires the kernel autofs to be version 5, which (as of
2.6.16.20) is not in the mainline kernel (only versions 3 and 4 are in the
mainline kernel). As a result, if you want to use a non-Fedora supplied kernel,
autofs breaks. Either the daemon should be able to work with version 4, or get
version 5 into the mainline kernel.

Version-Release number of selected component (if applicable):
autofs-5.0.0_beta4-11
Kernel 2.6.16.16 and 2.6.16.20

How reproducible:
Every time

Steps to Reproduce:
1. Build a kernel from sources obtained from kernel.org
2. boot into the kernel

  
Actual results:
Autofs dies with the following logged:
Jun 17 10:40:05 surfer kernel: autofs: kernel does not match daemon version
daemon (5, 5) kernel (3, 4)
Jun 17 10:40:05 surfer automount[23377]: do_mount_autofs_indirect: failed to
mount autofs path /misc
Jun 17 10:40:05 surfer automount[23377]: handle_mounts: mount of /misc failed!
Jun 17 10:40:05 surfer automount[23377]: master_do_mount: failed to startup mount
Jun 17 10:40:05 surfer automount[23377]: master_read_master: no mounts in table


Expected results:
Daemon should at least support V4 autofs and work.

Additional info:
Comment 1 Ian Kent 2006-06-18 02:19:37 EDT
(In reply to comment #0)
> Description of problem:
> The autofs daemon requires the kernel autofs to be version 5, which (as of
> 2.6.16.20) is not in the mainline kernel (only versions 3 and 4 are in the
> mainline kernel). As a result, if you want to use a non-Fedora supplied kernel,
> autofs breaks. Either the daemon should be able to work with version 4, or get
> version 5 into the mainline kernel.

You aren't using a Rawhide kernel.
Protocol version 5 requires 2.6.17 or above (Rawhide kernel includes
the current 2.6.17 rc patches).

> 
> 
> Expected results:
> Daemon should at least support V4 autofs and work.

It does but it requires the protocol version 5 patches to work.

Ian
Comment 2 Ian Kent 2006-06-21 20:57:36 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > The autofs daemon requires the kernel autofs to be version 5, which (as of
> > 2.6.16.20) is not in the mainline kernel (only versions 3 and 4 are in the
> > mainline kernel). As a result, if you want to use a non-Fedora supplied kernel,
> > autofs breaks. Either the daemon should be able to work with version 4, or get
> > version 5 into the mainline kernel.
> 
> You aren't using a Rawhide kernel.
> Protocol version 5 requires 2.6.17 or above (Rawhide kernel includes
> the current 2.6.17 rc patches).
> 
> > 
> > 
> > Expected results:
> > Daemon should at least support V4 autofs and work.
> 
> It does but it requires the protocol version 5 patches to work.

Can you try this with a Rawhide or FC6 test1 kernel please.
Comment 3 david.hagood 2006-06-22 07:50:29 EDT
It works with both a self-built 2.6.17 and a RH built kernel - however, at the
time of my submitting this bug 2.6.17 was not available, and a kernel built from
sources pulled from kernel.org only supported V4, not V5. As such, autofs really
should NOT have been V5 *only* - it should have supported V4 and V5.
Comment 4 Ian Kent 2006-06-22 09:53:46 EDT
(In reply to comment #3)
> It works with both a self-built 2.6.17 and a RH built kernel - however, at the
> time of my submitting this bug 2.6.17 was not available, and a kernel built from
> sources pulled from kernel.org only supported V4, not V5. As such, autofs really
> should NOT have been V5 *only* - it should have supported V4 and V5.
> 

The Rawhide kernel that I expected would be used was fine.
Due to tight schedules and the need to get this out to people
to test we decided to put it into Rawhide.

Sorry about the inconvenience but we really had to do it
this way.

Ian
Comment 5 Ian Kent 2006-06-27 22:28:21 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > It works with both a self-built 2.6.17 and a RH built kernel - however, at the
> > time of my submitting this bug 2.6.17 was not available, and a kernel built from
> > sources pulled from kernel.org only supported V4, not V5. As such, autofs really
> > should NOT have been V5 *only* - it should have supported V4 and V5.
> > 
> 
> The Rawhide kernel that I expected would be used was fine.
> Due to tight schedules and the need to get this out to people
> to test we decided to put it into Rawhide.
> 
> Sorry about the inconvenience but we really had to do it
> this way.

One other thing that I'd like to mention about this issue is
that the documentation in package /usr/share/doc directory had
the information about this requirement. The patches needed and
instructions on what kernels need them was also their. There is
a small paragraph in the INSTALL file that gives an example of
how to use the srpm to rebuild an FC5 kernel.

So, once again sorry, but the issue was documented.

Ian

Note You need to log in before you can comment on or make changes to this bug.