Bug 195790 - loading aha152x kernel module freezes system under FC5
loading aha152x kernel module freezes system under FC5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-17 15:54 EDT by Hugues Mercusot
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.17-1.2145_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-06 17:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some system informations reported just before freezing (dmesg and /proc/scsi) (22.03 KB, text/plain)
2006-06-17 15:54 EDT, Hugues Mercusot
no flags Details
Status of system before modprobe aha152x (to compare) (18.77 KB, text/plain)
2006-06-17 15:57 EDT, Hugues Mercusot
no flags Details
View of the card from Windows XP under which it works fine with same parameters and switches (72.77 KB, application/vnd.oasis.opendocument.text)
2006-06-17 16:00 EDT, Hugues Mercusot
no flags Details
Intermediate informations after modprobe and before first attachment for this bug. (22.02 KB, text/plain)
2006-06-17 16:02 EDT, Hugues Mercusot
no flags Details

  None (edit)
Description Hugues Mercusot 2006-06-17 15:54:08 EDT
Description of problem:
Loading aha152x module using modprobe aha152x io=0x140 irq=9 get to freeze
system after a while.
The SCSI card is ok on Windows XP and the configuration worked on FC3.

Version-Release number of selected component (if applicable):
kernel-2.6.16-1.2133_FC5

How reproducible:
modprobe aha152x io=0x140 irq=9

Steps to Reproduce:
1. modprobe aha152x io=0x140 irq=9
2. waiting a while ... it freezes ...
3.
  
Actual results:
aha152x: BIOS test: passed, 1 controller(s) configured
aha152x: resetting bus...
aha152x1: vital data: rev=1, io=0x140 (0x140/0x140), irq=9, scsiid=7,
reconnect=enabled, parity=enabled, synchronous=enabled, delay=1000, extended
translation=disabled
aha152x1: trying software interrupt, ok.
scsi1 : Adaptec 152x SCSI driver; $Revision: 2.7 $
(scsi1:0:0) Synchronous Data Transfer Request period = 200 ns offset = 8 
  Vendor: SEAGATE   Model: ST19101W          Rev: 0014
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdb: 17783240 512-byte hdwr sectors (9105 MB)
sdb: Write Protect is off
sdb: Mode Sense: b7 00 10 08
SCSI device sdb: drive cache: write back w/ FUA
SCSI device sdb: 17783240 512-byte hdwr sectors (9105 MB)
sdb: Write Protect is off
sdb: Mode Sense: b7 00 10 08
SCSI device sdb: drive cache: write back w/ FUA
 sdb: sdb1
sd 1:0:0:0: Attached scsi disk sdb
sd 1:0:0:0: Attached scsi generic sg2 type 0
(scsi-1:-1:-1) reselection missed?<3>(scsi1:0:0) cannot abort running or
disconnected command
(scsi1:3:0) cannot reuse command

AND FREEZE

Expected results:
new disk sdb1 available for mounting

Additional info:
The IRQ and IO options are ok because it's an ISA card with switches and it
works under Windows XP (multi boot system).
After freezing, the card is in such a state that I have to power off the
computer to get the card working under Windows too. A simple reset is not enough.
I have another SCSI card plugged in PCI bus (aic7xxx module) that works fine.
And no problem with usb keys or wireless until modprobing aha152x.
Comment 1 Hugues Mercusot 2006-06-17 15:54:08 EDT
Created attachment 131109 [details]
Some system informations reported just before freezing (dmesg and /proc/scsi)
Comment 2 Hugues Mercusot 2006-06-17 15:57:16 EDT
Created attachment 131110 [details]
Status of system before modprobe aha152x (to compare)
Comment 3 Hugues Mercusot 2006-06-17 16:00:40 EDT
Created attachment 131111 [details]
View of the card from Windows XP under which it works fine with same parameters and switches

This is an OOo writer file with screenshots
Comment 4 Hugues Mercusot 2006-06-17 16:02:39 EDT
Created attachment 131112 [details]
Intermediate informations after modprobe and before first attachment for this bug.

Hope this help ...
Comment 5 Hugues Mercusot 2006-07-03 15:04:01 EDT
It's exactly the same with kernel 2.6.17-1.2139_FC5
Comment 6 Hugues Mercusot 2006-07-06 17:37:28 EDT
Seems to works fine yet after kernel 2.6.17-1.2145_FC5 update.

Note You need to log in before you can comment on or make changes to this bug.