Bug 195814 - udev fails to create joystick symlink js# with USB gamepad
udev fails to create joystick symlink js# with USB gamepad
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 01:39 EDT by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 06:35:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2006-06-18 01:39:46 EDT
Description of problem:
Udev (or is it DBus?) fails to create symlink for USB joystick devices. I have
two Wingman Rumble Pads which worked flawlessly with FC4 (x86_64 and i386),
however in FC5 when plugged, the symlink from /dev/input/event# to
/dev/input/js# is not made (making it rather difficult to use the joysticks as
the applications I want to use them with expect js#)

Version-Release number of selected component (if applicable):
udev-084-13

How reproducible:
Always

Steps to Reproduce:
1. Boot system with joystic(s) plugged.
2. See contents of /dev/input
3. unplug and replug, see dmesg
  
Actual results:
The js# symbolic links are not created.

Expected results:
The js# symbolic links to be created.

Additional info:
Mybe this is something about udev's rules or something?

Here's my relevant dmesg messages:
usb 1-2.1: USB disconnect, address 8
usb 4-1: new low speed USB device using uhci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
drivers/usb/input/hid-core.c: timeout initializing reports
input: Logitech Inc. WingMan RumblePad as /class/input/input4
input: USB HID v1.10 Joystick [Logitech Inc. WingMan RumblePad] on
usb-0000:00:10.3-1

It doesn't matter what kernel I run.
Comment 1 Harald Hoyer 2006-09-29 10:18:49 EDT
Does it help, if you load the joystick module by hand?
# /sbin/modprobe joydev

Note You need to log in before you can comment on or make changes to this bug.