Bug 195828 - setting DEBUG for adsl-start causes adsl-connect to exit
setting DEBUG for adsl-start causes adsl-connect to exit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rp-pppoe (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 05:21 EDT by pauwel coppieters
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 14:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description pauwel coppieters 2006-06-18 05:21:11 EDT
Description of problem:
Setting the DEBUG variable in during pppoe startup causes adsl-connect to stop
with the message
If you want to use DEBUG, invoke adsl-start, not adsl-connect

Version-Release number of selected component (if applicable):
rp-pppoe-3.5-31

How reproducible:
Always. It is a simple bug in the script, but I can't find a maintainer for
adsl-start and adsl-connect.

Steps to Reproduce:
1. $ export DEBUG=1
2. # launch adsl-start 
3.




Actual results:


Expected results:


Additional info:
adsl-start contains the lines (these lines start adsl-connect)

# Start the connection in the background unless we're debugging
if [ "$DEBUG" = "1" ] ; then
    $CONNECT "$@"
    exit 0
fi

and adsl-connect checks that DEBUG <> 1 because it want's DEBUG to be a file name
lines from adsl-connect :

# Catch common error
if test "$DEBUG" = "1" ; then
    echo "*** If you want to use DEBUG, invoke adsl-start, not adsl-connect."
    exit 1
fi
Comment 1 Ngo Than 2007-03-20 14:57:17 EDT
it's fixed in 3.8-2.fc7. it should be available in rawhide soon. Thanks for 
your report.

Note You need to log in before you can comment on or make changes to this bug.