Bug 195829 - Native LCD panel resolution not supported (MacBook)
Native LCD panel resolution not supported (MacBook)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 06:07 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-19 15:26:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-06-18 06:07:48 EDT
Description of problem:
The current i810 driver does not support the native 1280x800 resolution of the
Apple MacBook and falls back to 1024x768.

Version-Release number of selected component (if applicable):
Rawhide 16-Jun-06

How reproducible:
Allways

Steps to Reproduce:
1. Select LCD panel of 1280x800
2. Configure X by editing xorg.conf -> default resolution = 1280x800
3. Restart X
  
Actual results:
The max. resolution is 1024x768

Expected results:
Max. resolution is 1280x800

Additional info:
An updated i810 xorg driver or using 915resolution is probably needed to fix the
problem.
Comment 1 Mike A. Harris 2006-06-19 15:26:42 EDT
This is a frequently reported issue on laptops with Intel based video,
as well as some systems which use DFP/LCD displays.  The problem is
a bug in the video BIOS, which does not support the resolution that
is being requested.

It is very unfortunate that many manufacturers make laptops with
native panel sizes not supported by their own video BIOS.

Intel is currently working on new driver support which will enable the
i810 driver to directly set the video mode without using the BIOS.  This
support will be available in a future release of the driver.

In the mean time, you can download the i810/i915resolution utilities
and attempt to use them to work around the bug in your video BIOS, however
there is no guarantee that it will actually work.  If you require any
additional assistance in trying to coax the required video mode to work,
the xorg@lists.freedesktop.org mailing list may be able to assist.

Hope this helps.

Setting status to "CANTFIX" (video BIOS bug).

Note You need to log in before you can comment on or make changes to this bug.