Bug 19584 - sasl_pwcheck_method:sasldb broken
sasl_pwcheck_method:sasldb broken
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: cyrus-sasl (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 00:18 EDT by Darren Nickerson
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Nickerson 2000-10-23 00:18:19 EDT
I'm not sure if the use of sasldb was tested or not, but it seems to be
broken in the recent cyrus-sasl-1.5.24-6

[root@hewes SRPMS]# cat /etc/imapd.conf
# See imapd.conf(5)
configdirectory: /var/imap
partition-default: /var/spool/imap
admins: root cyrus darren
allowanonymouslogin: no
sasl_pwcheck_method:sasldb

[root@hewes SRPMS]# sasldblistusers
can't open /etc/sasldb

Which is strange, since it exists:

[root@hewes SRPMS]# ls -al /etc/sasldb 
-rw-rw-r--    1 cyrus    mail        16384 Oct  3 00:09 /etc/sasldb


I actually moved that file, created a new /etc/sasldb mode 777 and tried
again. Still no joy.

Upgrading to RH7 broke my cyrus imapd install. Backing out to my previous
version of cyrus-sasl:

[root@hewes i386]# rpm -Uvh --oldpackage cyrus-sasl-1.5.20-1.i386.rpm 
cyrus-sasl                 
##################################################
/sbin/ldconfig: Input file /usr/X11R6/lib/libforms.so not found.

/sbin/ldconfig: Input file /usr/X11R6/lib/libforms.so not found.


(EH? What's that about libforms? Looks like a problem with my
xforms-devel-0.88-9)

Anyway, I now have a working sasl setup:

[root@hewes i386]# sasldblistusers
user: darren realm: hewes.dazza.org mech: PLAIN
user: root realm: hewes.dazza.org mech: PLAIN
user: svi realm: hewes.dazza.org mech: PLAIN
user: wibble realm: hewes.dazza.org mech: PLAIN
user: wibble realm: hewes.dazza.org mech: CRAM-MD5
user: testuser realm: hewes.dazza.org mech: PLAIN
user: testuser realm: hewes.dazza.org mech: CRAM-MD5
user: svi realm: hewes.dazza.org mech: CRAM-MD5
user: root realm: hewes.dazza.org mech: CRAM-MD5

*phew*

Not sure what the fix is, but for me, the cyrus-sasl you shipped is bust.

-Darren
Comment 1 Nalin Dahyabhai 2000-10-24 15:12:36 EDT
I can't reproduce this here.  Since we didn't have a cyrus-sasl-1.5.20-1 in
Power Tools, I think your package was built elsewhere.  Did it use gdbm as the
storage back-end for the sasldb, as the versions we've shipped do?  Berkeley
DB's on-disk format is different.
Comment 2 Darren Nickerson 2000-10-24 15:17:33 EDT
You missed the point. Here's a virgin RedHat-7.0 install:

[root@mail2 /root]# cat /etc/redhat-release 
Red Hat Linux release 7.0 (Guinness)
[root@mail2 /root]# rpm -q cyrus-sasl
cyrus-sasl-1.5.24-6

[root@mail2 /root]# sasldblistusers 
can't open /etc/sasldb

BROKEN!
Comment 3 Bill Nottingham 2006-10-18 14:13:00 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.