Bug 195845 - IPv6 critical error message
IPv6 critical error message
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-18 14:10 EDT by Florian La Roche
Modified: 2014-03-16 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.52-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 20:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2006-06-18 14:10:12 EDT
Description of problem:

Adding "install ipv6 /bin/true" to /etc/modprobe.conf gives two
error messages during startup that the kernel is compiled without
ipv6 support.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2006-06-19 11:38:25 EDT
I don't see these messages anywhere in initscripts code, nor in a test boot of
fairly minimal install. These error messages must be coming from somewhere else.
Comment 2 Florian La Roche 2006-06-19 13:58:28 EDT
./sysconfig/network-scripts/network-functions-ipv6
Function seems to be ipv6_test()

regards,

Florian La Roche
Comment 3 Bill Nottingham 2006-06-19 14:07:30 EDT
Please attach your network config.
Comment 4 Florian La Roche 2006-06-19 14:31:58 EDT
Logs for this should help a lot, as it already shows up pretty early:

INIT: Entering runlevel: 3
Entering non-interactive startup
CRITICAL : [ipv6_test] Kernel is not compiled with IPv6 support
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  prism54 device eth0 does not seem to be present,
delaying initialization.
                                                           [FAILED]
CRITICAL : [ipv6_test] Kernel is not compiled with IPv6 support
Starting system logger:                                    [  OK  ]
Starting kernel logger:                                    [  OK  ]


Don't think this relates to the actual network config:
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.123.127
NETMASK=255.255.255.0
HWADDR=00:01:36:0D:CE:17
ONBOOT=yes
ESSID=laroche
CHANNEL=6


prism54 errors are probably already in some other bz, I have local workarounds
to get this started.

regards,

Florian La Roche
Comment 5 Bill Nottingham 2006-06-19 14:48:15 EDT
/etc/sysconfig/network?
Comment 6 Bill Nottingham 2007-04-16 20:08:47 EDT
Fixed in 8.52-1.

Note You need to log in before you can comment on or make changes to this bug.