Bug 19585 - ssh-askpass rejecting first input
ssh-askpass rejecting first input
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 01:44 EDT by Brad P. Crochet
Modified: 2007-04-18 12:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 07:45:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad P. Crochet 2000-10-23 01:44:03 EDT
ssh-askpass is rejecting the first input of a passphrase for a DSA key when
the key is explicitly specified on the command line. Whenever I specify the
DSA key for protocol 2 on the command line, I input the passhrase, it
rejects it, and then reinput, and it is accepted. If I just use an
'ssh-add' command line with no keys specified, it functions properly.
Comment 1 Nalin Dahyabhai 2000-10-24 15:01:49 EDT
Are you running the errata release of OpenSSH?  If so, do you also have an RSA
key?  I'm not able to reproduce this behavior.
Comment 2 Brad P. Crochet 2000-10-24 16:35:18 EDT
[bcrochet@dredd bcrochet]$ rpm -qa | grep openssh
openssh-askpass-gnome-2.2.0p1-5
openssh-askpass-2.2.0p1-5
openssh-clients-2.2.0p1-5
openssh-2.2.0p1-5
openssh-server-2.2.0p1-5

[bcrochet@dredd bcrochet]$ ls -l .ssh
total 32
-rw-rw-r--    1 bcrochet bcrochet      681 Oct 21 21:24 authorized_keys
-rw-------    1 bcrochet bcrochet     1241 Oct 21 20:38 authorized_keys2
-rw-------    1 bcrochet bcrochet      736 Oct 21 19:53 id_dsa
-rw-rw-r--    1 bcrochet bcrochet      604 Oct 21 19:53 id_dsa.pub
-rw-------    1 bcrochet bcrochet      529 Oct 21 19:52 identity
-rw-rw-r--    1 bcrochet bcrochet      333 Oct 21 19:52 identity.pub
-rw-r--r--    1 bcrochet bcrochet      349 Oct 21 21:37 known_hosts
-rw-r--r--    1 bcrochet bcrochet     1839 Oct 21 21:48 known_hosts2

My .xsession contains:
[bcrochet@dredd bcrochet]$ cat .xsession
exec /usr/bin/ssh-agent ./.xsession.real

[bcrochet@dredd bcrochet]$ cat .xsession.real 
/usr/bin/ssh-add $HOME/.ssh/id_dsa </dev/null > /dev/null 2>&1
/usr/bin/ssh-add $HOME/.ssh/identity </dev/null > /dev/null 2>&1
gnome-session

I was able to reproduce this on 2 machines. A Dell Inspiron 5000 Laptop, and a
home-grown PII-450.


Comment 3 Martin C. Messer 2000-11-20 00:51:36 EST
I'm seeing the exact same behavior. It seems to be limited to 

/usr/libexec/ssh/gnome-ssh-askpass

because when I do this in .bash_profile:

SSH_ASKPASS=/usr/libexec/ssh/x11-ssh-askpass

the passphrase app accepts my initial input.

Comment 4 vigna 2001-11-04 17:51:05 EST
Same problem here on RedHat 7.0, 7.1 and 7.2. Using the standard ssh askpass
application instead of the GNOME version solves the problem, so it seems really
to be a problem of gnome-ssh-askpass...
Comment 5 Damien Miller 2003-02-09 22:39:42 EST
This was fixed in OpenSSH 3.1p1. This bug may be safely closed.

Note You need to log in before you can comment on or make changes to this bug.