Bug 195875 - X hard locks after pm-suspend
X hard locks after pm-suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 01:03 EDT by Aaron Luchko
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.18-1.2798.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 02:33:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
relevant section of /var/log/messages (2.94 KB, text/plain)
2006-06-19 01:04 EDT, Aaron Luchko
no flags Details
auto-generated xorg.conf (2.80 KB, application/octet-stream)
2006-06-19 01:09 EDT, Aaron Luchko
no flags Details

  None (edit)
Description Aaron Luchko 2006-06-19 01:03:03 EDT
Description of problem:
When reawakening the computer after running pm-suspend the moment one switches
to an X-session the machine hardlocks.

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.16-1.2133_FC5 #1 Tue Jun 6 00:52:14 EDT 2006
i686 i686 i386 GNU/Linux


How reproducible:
Always

Steps to Reproduce:
1. run pm-suspend
2. reawaken computer
3. if you were in an X-session the machine will already be hardlocked, if X is
running in another virtual terminal switch to that terminal and the machine will
hardlock.

Additional info:
I've attempted this both with the default auto-configuration of the display and
with dual monitors, interestingly with dual monitors the second monitor does
display an image (before hardlocking) though the resolution is extremely low.

These are the specs for the laptop
http://h10025.www1.hp.com/ewfrf/wc/genericDocument?cc=ca&docname=c00500901&lc=en
Comment 1 Aaron Luchko 2006-06-19 01:04:32 EDT
Created attachment 131126 [details]
relevant section of /var/log/messages
Comment 2 Aaron Luchko 2006-06-19 01:09:04 EDT
Created attachment 131127 [details]
auto-generated xorg.conf
Comment 3 Aaron Luchko 2006-09-30 23:47:46 EDT
This bug still exists with kernel-2.6.17-1.2187_FC5
Comment 4 Dave Jones 2006-10-16 20:49:56 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Aaron Luchko 2006-11-10 02:33:22 EST
Last time I tried this still existed under fc5, however after upgrading to fc6
suspend has worked successfully. Since I can no longer test on fc5 and the bug
doesn't exist under fc6 I'm marking it as resolved.

Note You need to log in before you can comment on or make changes to this bug.