Bug 195879 - Broken upgrade path FC5->FC6
Broken upgrade path FC5->FC6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-X11-Protocol (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Duncan Ferguson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 03:41 EDT by Paul Howarth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-18 10:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2006-06-19 03:41:08 EDT
The latest release of perl-X11-Protocol in the FC-5 branch is "later"
(0.55-4.fc5) than the one in the devel branch (0.55-3.fc6), which means that
people upgrading from FC-5 to FC-6 won't get the FC-6 version.

You need to bump the release number of all "later" branches when you do a new
build for an earlier branch. Using the %{?dist} tag, as is the case in this
package, helps here; you can just use the same spec file and release number in
all branches and build them all whenever you make a change, which results in
clean upgrade paths.
Comment 1 Duncan Ferguson 2006-06-20 02:36:06 EDT
Spec file modified and new build requested.  Will mark this bug as completed
when I have comfirmation a new rpm has successfully been built.
Comment 2 David Lawrence 2006-07-17 23:00:48 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.