Bug 195898 - Kernel BUG message in /var/log/messages
Kernel BUG message in /var/log/messages
Status: CLOSED DUPLICATE of bug 194597
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 09:13 EDT by Eric Hopper
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 17:15:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hopper 2006-06-19 09:13:21 EDT
Description of problem: I've been seeing odd application lockups that appear
related to sound, and I've gotten this message in the logs.


Version-Release number of selected component (if applicable): 2.6.16-1.2133_FC5


How reproducible: I've only seen the message once, and am not sure what sequence
of events led to it, but I suspect this happend while I was trying to use rmmod
to remove modules from the kernel to reset the OSS ALSA layer so any program
that used it would stop locking up on opening the device.


Steps to Reproduce:
1. I'm guessing you should try removing modules using rmmod.


Additional info:
This kernel was tainted.  I'm sorry that this is true, and don't like the nVidia
people much either.  But since this is a machine I actually use, you are highly
unlikely to ever get a bug report from me at least that has an untainted kernel.
 I understand if this means you have to toss this, but it seems to me like
you're wasting valuable information and cutting off your nose to spite your face.

Jun 18 17:51:37 bats kernel: List corruption. next->prev should be
ffff81007e89ea50, but was ffff81007efee800
Jun 18 17:51:37 bats kernel: ----------- [cut here ] --------- [please bite here
] ---------
Jun 18 17:51:37 bats kernel: Kernel BUG at include/linux/list.h:58
Jun 18 17:51:37 bats kernel: invalid opcode: 0000 [1] SMP 
Jun 18 17:51:37 bats kernel: last sysfs file: /block/hda/size
Jun 18 17:51:37 bats kernel: CPU 0 
Jun 18 17:51:37 bats kernel: Modules linked in: xt_limit loop tun autofs4
ip_conntrack_netbios_ns ip_conntrack nfnetlink ipt_REJECT xt_tcpudp
iptable_filter ip_tables x_tables reiserfs video button battery ac ipv6 lp
parport_pc parport usb_storage nvram nvidia(U) ohci1394 ieee1394 ohci_hcd sg
snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss tg3 snd_mixer_oss snd_pcm
hw_random i2c_amd8111 snd_timer i2c_amd756 snd soundcore i2c_core snd_page_alloc
dm_snapshot dm_zero dm_mirror dm_mod raid0 raid1 ext3 jbd sata_sil libata sd_mod
scsi_mod
Jun 18 17:51:37 bats kernel: Pid: 28457, comm: rmmod Tainted: P     
2.6.16-1.2133_FC5 #1
Jun 18 17:51:37 bats kernel: RIP: 0010:[<ffffffff881e811e>]
<ffffffff881e811e>{:snd_seq:snd_seq_delete_all_ports+145}
Jun 18 17:51:37 bats kernel: RSP: 0000:ffff81004a8c9e68  EFLAGS: 00010086
Jun 18 17:51:37 bats kernel: RAX: 0000000000000054 RBX: ffff81007e89ea50 RCX:
00000000000063ef
Jun 18 17:51:37 bats kernel: RDX: 0000000000000000 RSI: 0000000000000096 RDI:
ffffffff803c89e0
Jun 18 17:51:37 bats kernel: RBP: ffff81007e89ea50 R08: ffffffff803c89f8 R09:
ffff81007e0b8040
Jun 18 17:51:37 bats kernel: R10: 0000000000000010 R11: 0000000000000000 R12:
ffff81007efee780
Jun 18 17:51:37 bats kernel: R13: ffff81007efee800 R14: ffff81007efee828 R15:
ffff81007efee810
Jun 18 17:51:37 bats kernel: FS:  00002aaaaaad0210(0000)
GS:ffffffff80514000(0000) knlGS:00000000f57a0ba0
Jun 18 17:51:37 bats kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jun 18 17:51:37 bats kernel: CR2: 0000003d13302cc0 CR3: 000000004e7b5000 CR4:
00000000000006e0
Jun 18 17:51:37 bats kernel: Process rmmod (pid: 28457, threadinfo
ffff81004a8c8000, task ffff8100290e9040)
Jun 18 17:51:37 bats kernel: Stack: ffff81004a796040 0000000000000246
ffffffff8014e0a2 00007fffffa807b0 
Jun 18 17:51:37 bats kernel:        ffff81004a796050 ffff81007efee780
ffffffff8821af00 0000000000000000 
Jun 18 17:51:37 bats kernel:        0000000000000880 00007fffffa807b0 
Jun 18 17:51:37 bats kernel: Call Trace: <ffffffff8014e0a2>{__try_stop_module+0}
Jun 18 17:51:37 bats kernel:       
<ffffffff881e21fa>{:snd_seq:seq_free_client1+9}
<ffffffff881e22ee>{:snd_seq:seq_free_client+89}
Jun 18 17:51:37 bats kernel:       
<ffffffff881e4ea1>{:snd_seq:snd_seq_delete_kernel_client+42}
Jun 18 17:51:37 bats kernel:        <ffffffff8014e34f>{sys_delete_module+551}
<ffffffff8010a7ba>{system_call+126}
Jun 18 17:51:37 bats kernel: 
Jun 18 17:51:37 bats kernel: Code: 0f 0b 68 e6 95 1e 88 c2 3a 00 48 8b 55 00 48
39 da 74 1b 48 
Jun 18 17:51:37 bats kernel: RIP
<ffffffff881e811e>{:snd_seq:snd_seq_delete_all_ports+145} RSP <ffff81004a8c9e68>
Jun 18 17:51:37 bats kernel:  <3>Debug: sleeping function called from invalid
context at include/linux/rwsem.h:43
Jun 18 17:51:37 bats kernel: in_atomic():0, irqs_disabled():1
Jun 18 17:51:37 bats kernel: 
Jun 18 17:51:37 bats kernel: Call Trace: <ffffffff80133d13>{profile_task_exit+21}
Jun 18 17:51:37 bats kernel:        <ffffffff801354c2>{do_exit+32}
<ffffffff8010c184>{kernel_math_error+0}
Jun 18 17:51:37 bats kernel:        <ffffffff8010c711>{do_invalid_op+163}
<ffffffff881e811e>{:snd_seq:snd_seq_delete_all_ports+145}
Jun 18 17:51:37 bats kernel:        <ffffffff80132ce5>{printk+82}
<ffffffff8010b691>{error_exit+0}
Jun 18 17:51:37 bats kernel:       
<ffffffff881e811e>{:snd_seq:snd_seq_delete_all_ports+145}
Jun 18 17:51:37 bats kernel:       
<ffffffff881e811e>{:snd_seq:snd_seq_delete_all_ports+145}
Jun 18 17:51:37 bats kernel:        <ffffffff8014e0a2>{__try_stop_module+0}
<ffffffff881e21fa>{:snd_seq:seq_free_client1+9}
Jun 18 17:51:37 bats kernel:       
<ffffffff881e22ee>{:snd_seq:seq_free_client+89}
<ffffffff881e4ea1>{:snd_seq:snd_seq_delete_kernel_client+42}
Jun 18 17:51:37 bats kernel:        <ffffffff8014e34f>{sys_delete_module+551}
<ffffffff8010a7ba>{system_call+126}
Comment 1 Leonard den Ottolander 2006-06-20 17:01:48 EDT
Looks like a duplicate of bug 194597.
Comment 2 Eric Hopper 2006-06-20 17:15:32 EDT
It likely is at least partly the same bug.  In fact, that's the only concrete
symptom I can point at.

I've been seeing other odd sound problems in which an ALSA using application can
no longer use the sound card (acts like something else is using it) after an OSS
application has used it and is done with it.  But I have no good, concrete
reproducible example, and it should probably be its own bug anyway.

*** This bug has been marked as a duplicate of 194597 ***

Note You need to log in before you can comment on or make changes to this bug.