Bug 195915 - /dev/pilot randomly linked to ttyUSB0 or ttyUSB1
/dev/pilot randomly linked to ttyUSB0 or ttyUSB1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 11:46 EDT by Ian Pilcher
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 07:04:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of 'udevinfo -a' for ttyUSB0 (2.88 KB, text/plain)
2006-06-20 11:16 EDT, Ian Pilcher
no flags Details
output of 'udevinfo -a' for ttyUSB1 (2.88 KB, text/plain)
2006-06-20 11:17 EDT, Ian Pilcher
no flags Details
output of 'lsusb -vvv' for Treo650 (2.60 KB, text/plain)
2006-06-20 11:18 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2006-06-19 11:46:51 EDT
Description of problem:

When I connect my Treo650 and press the sync button, /dev/ttyUSB0 and
/dev/ttyUSB1 are created.  /dev/pilot is created, but it randomly(?)
points to either ttyUSB0 or ttyUSB1.  /dev/pilot should always be linked
to ttyUSB1.


Version-Release number of selected component (if applicable):

udev-084-13


How reproducible:

50%


Steps to Reproduce:
1.  Connect Treo650 via USB cable
2.  Press sync button
3.  ls -l /dev/pilot
4.  lather, rinse, repeat

  
Actual results:

/dev/pilot is linked to ttyUSB0 or ttyUSB1, apparently randomly.


Expected results:

/dev/pilot should always link to ttyUSB1.


Additional info:
Comment 1 Harald Hoyer 2006-06-20 06:21:39 EDT
what, if other devices are connected to the USB Bus?
Comment 2 Ian Pilcher 2006-06-20 11:16:58 EDT
Created attachment 131201 [details]
output of 'udevinfo -a' for ttyUSB0
Comment 3 Ian Pilcher 2006-06-20 11:17:50 EDT
Created attachment 131202 [details]
output of 'udevinfo -a' for ttyUSB1
Comment 4 Ian Pilcher 2006-06-20 11:18:51 EDT
Created attachment 131203 [details]
output of 'lsusb -vvv' for Treo650
Comment 5 Ian Pilcher 2006-06-20 11:29:41 EDT
(In reply to comment #1)
> what, if other devices are connected to the USB Bus?

/dev/pilot needs to be linked to the higher-numbered port of the two ports
that are created for a Treo.  Unfortunately, there doesn't appear to be any
easy was to distinguish them.  I have attached the output of 'udevinfo -a'
for both ports, along with the output of 'lsusb -vvv'.
Comment 6 Harald Hoyer 2006-06-21 04:34:20 EDT
Why not fix the applications, that use the device. Why does such a device
specific decision have to live in udev?
Comment 7 Ian Pilcher 2006-06-21 10:09:12 EDT
(In reply to comment #6)
> Why not fix the applications, that use the device. Why does such a device
> specific decision have to live in udev?

Because it's udev's job to give persistent names (/dev/pilot) to devices that
appear at different physical locations (/dev/ttyUSB?).

Note You need to log in before you can comment on or make changes to this bug.