Bug 195934 - anaconda using incorrect NIC when pulling dhcp ip
Summary: anaconda using incorrect NIC when pulling dhcp ip
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 197300 (view as bug list)
Depends On:
Blocks: 202651
TreeView+ depends on / blocked
 
Reported: 2006-06-19 18:49 UTC by James Laska
Modified: 2014-03-17 03:00 UTC (History)
8 users (show)

Fixed In Version: RHEL5B1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-08 20:14:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 25067 None None None Never

Description James Laska 2006-06-19 18:49:52 UTC
# TREE rel-eng/FC6-Test1-re20060616.0/5.90
# ARCH ppc

1) 
            âââââââââââââââââ⤠Networking Device âââââââââââââââââââ
            â                                                      â
            â You have multiple network devices on this system.    â
            â Which would you like to install through?             â
            â                                                      â
            â eth0 - IBM i/pSeries Virtual Ethernet                â
            â eth1 - Intel Corporation PRO/10GbE SR Server Adapter â
            â                                                      â
            â          ââââââ                   ââââââââ           â
            â          â OK â                   â Back â           â
            â          ââââââ                   ââââââââ           â
            â                                                      â
            â                                                      â
            ââââââââââââââââââââââââââââââââââââââââââââââââââââââââ

2) Select eth0 (virtual ethernet)
  System sits at the following screen *forever*
         âââââââââââââââââââââ⤠Configure TCP/IP âââââââââââââââââââââââ
         â                                                             â
         â Please enter the IP configuration for this machine. Each    â
         â item should be entered as an IP address in dotted-decimal   â
         â notation (for example, 1.2.3.4).                            â
         â                                                             â
         â        [*] Use dynamic IP configuration (BOOTP/DHCP)        â
         â  âââââââââââââââââââââ⤠Dynamic IP âââââââââââââââââââââââ  â
         â  â                                                       â  â
         â  â Sending request for IP information for eth0...        â  â
         â  â                                                       â  â
         â  ââââââââââââââââââââââââââââââââââââââ <94><80>ââââââââââââââââââ  â
         â                                                             â
         â            ââââââ                       ââââââââ            â
         â            â OK â                       â Back â            â
         â            ââââââ                       ââââââââ            â
         â                                                             â
         â                                                             â
         ââââââââââââââââ  <80>ââââââââââââââââââââââââââââââââââââââââââ
<94><80>âââ


At the suggestion of Mike Gahagan, if I instead select eth1 (which is *not*
plugged in), it successfully pulls a DHCP ip.

          âââââââââââââââââââââââ⤠NFS Setup ââââââââââââââââââââââââ
          â                                                         â
          â Please enter the following information:                 â
          â                                                         â
          â     o the name or IP number of your NFS server          â
          â     o the directory on that server containing           â
          â       Fedora Core for your architecture                 â
          â                                                         â
          â     NFS server name:       ________________________     â
          â     Fedora Core directory: ________________________     â
          â                                                         â
          â          ââââââ                     ââââââââ            â
          â          â OK â                     â Back â            â
          â          ââââââ                     ââââââââ            â
          â                                                         â
          â                                                         â
          âââââââââââââââââââââââââââââââââââââââââââââââââââââââââââ

 .... onto stage2 ....

Running anaconda, the Fedora Core system installer - please wait...
Framebuffer ioctl failed. Exiting.
Probing for video card:   Unable to probe
Probing for monitor type:   Unknown monitor
No video hardware found, assuming headless

Comment 1 Jeremy Katz 2006-06-20 00:49:05 UTC
Can you get the output of kudzu -p -c NETWORK after install?

Comment 2 James Laska 2006-06-20 12:17:39 UTC
Indeed, meant to do this yesterday ... but distrsctions got the better of me ...

[root@localhost ~]# kudzu -p -c NETWORK
-
class: NETWORK
bus: VIO
detached: 0
device: eth1
driver: ibmveth
desc: "IBM i/pSeries Virtual Ethernet"
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: ixgb
desc: "Intel Corporation PRO/10GbE SR Server Adapter"
network.hwaddr: 00:0d:60:50:08:70
vendorId: 8086
deviceId: 1a48
subVendorId: 1014
subDeviceId: 02ba
pciType: 1
pcidom:    0
pcibus: d8
pcidev:  1
pcifn:  0
[

Trying to figure out why I can't get the network up post-install now ...
(possibly a different issue)

Comment 3 James Laska 2006-06-20 12:34:34 UTC
Umm ... this is strange (eth1 reported as dev1804289383)

# ip link list
1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: dev1804289383: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 46:2a:b0:00:70:02 brd ff:ff:ff:ff:ff:ff
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0d:60:50:08:70 brd ff:ff:ff:ff:ff:ff
4: sit0: <NOARP> mtu 1480 qdisc noop
    link/sit 0.0.0.0 brd 0.0.0.0


Comment 4 Jeremy Katz 2006-06-20 14:15:33 UTC
Can you move /etc/sysconfig/network-scripts/ifcfg* out of the way and then rerun
kudzu?  (The devXXXXX thing is due to some weird cases in interface renumbering
that Bill was working on rewriting)

Comment 5 James Laska 2006-06-20 15:11:50 UTC
(In reply to comment #4)
> Can you move /etc/sysconfig/network-scripts/ifcfg* out of the way and then rerun
> kudzu?  

[root@localhost ~]# rm -f /etc/sysconfig/network-scripts/ifcfg*

[root@localhost ~]# kudzu
Framebuffer ioctl failed. Exiting.

[root@localhost ~]# ls /etc/sysconfig/network-scripts/ifcfg*
ls: /etc/sysconfig/network-scripts/ifcfg*: No such file or directory

[root@localhost ~]# ip link list
1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: dev1804289383: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
    link/ether 46:2a:b0:00:70:02 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop qlen 1000
    link/ether 00:0d:60:50:08:70 brd ff:ff:ff:ff:ff:ff
4: sit0: <NOARP> mtu 1480 qdisc noop
    link/sit 0.0.0.0 brd 0.0.0.0



Comment 6 James Laska 2006-06-20 15:24:09 UTC
<jeremy> | whoops, I wasn't precise enough -- kudzu -p -c NETWORK

[root@localhost ~]# kudzu -p -c NETWORK
-
class: NETWORK
bus: VIO
detached: 0
device: eth0
driver: ibmveth
desc: "IBM i/pSeries Virtual Ethernet"
-
class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: ixgb
desc: "Intel Corporation PRO/10GbE SR Server Adapter"
network.hwaddr: 00:0d:60:50:08:70
vendorId: 8086
deviceId: 1a48
subVendorId: 1014
subDeviceId: 02ba
pciType: 1
pcidom:    0
pcibus: d8
pcidev:  1
pcifn:  0
[

Comment 7 Bill Nottingham 2006-06-29 03:41:17 UTC
Unsure what the issue is here. Are we sure that anaconda is sending the request
on the proper interface?

Comment 8 Jeremy Katz 2006-07-04 03:31:41 UTC
*** Bug 197300 has been marked as a duplicate of this bug. ***

Comment 9 IBM Bug Proxy 2006-07-05 18:17:24 UTC
197300 was against rhel5, we'll watch this one for that, too.

Comment 11 Bill Nottingham 2006-07-18 18:51:36 UTC
This only occurs on PPC with virtual ethernet, correct?

Comment 12 IBM Bug Proxy 2006-07-18 19:31:10 UTC
------- Additional Comments From yongwenw@us.ibm.com  2006-07-18 15:36 EDT -------
(In reply to comment #6)
> ----- Additional Comments From notting@redhat.com  2006-07-18 14:51 EST -----
--
> This only occurs on PPC with virtual ethernet, correct?
> -- 

Probably, since it needs more than 1 ethernet for the description to be mixed 
up, and we usually don't have 2 native ethernet on 1 partition, so so far we 
have only saw the problem in a partition with a mix of virtual ethernet and 
native ethernet. 

Comment 13 Bill Nottingham 2006-07-24 17:20:43 UTC
Got a local test machine?

Comment 14 IBM Bug Proxy 2006-07-24 17:50:45 UTC
------- Additional Comments From yongwenw@us.ibm.com  2006-07-24 13:57 EDT -------
(In reply to comment #8)
> ----- Additional Comments From notting@redhat.com  2006-07-24 13:20 EST -----
--
> Got a local test machine?
> -- 

Is this question for us? You can't get to our machines since you need to pass 
firewall with IBM ID and password. 

Comment 15 Bill Nottingham 2006-07-24 17:54:04 UTC
No, for the local-to-RH folks. Apologies.

Comment 16 Bill Nottingham 2006-07-25 18:30:00 UTC
Should be fixed in 1.2.40-1. You'll need an anaconda package built against that.

Comment 18 Bill Nottingham 2006-08-17 17:09:02 UTC
Which part is not working?

Comment 19 James Laska 2006-08-17 17:10:53 UTC
It prompts to select which NIC to use:

            âââââââââââââââââ⤠Networking Device âââââââââââââââââââ
            â                                                      â
            â You have multiple network devices on this system.    â
            â Which would you like to install through?             â
            â                                                      â
            â eth0 - IBM i/pSeries Virtual Ethernet                â
            â eth1 - Intel Corporation PRO/10GbE SR Server Adapter â
            â                                                      â
            â          ââââââ                   ââââââââ           â
            â          â OK â                   â Back â           â
            â          ââââââ                   ââââââââ           â
            â                                                      â
            â                                                      â
            ââââââââââââââââââââââââââââââââââââââââââââââââââââââââ

eth0 is plugged in (virtual), eth1 is not

However, I have to pick eth1 to get to the network.

Comment 20 Bill Nottingham 2006-08-17 17:13:11 UTC
Can you attach all the anaconda logs?

Comment 22 Bill Nottingham 2006-08-17 18:22:18 UTC
Fixed in 1.2.43-1, needs anaconda built against it, etc.

Comment 23 IBM Bug Proxy 2006-08-18 13:56:48 UTC
------- Additional Comments From yongwenw@us.ibm.com  2006-08-18 10:04 EDT -------
(In reply to comment #14)
> ----- Additional Comments From notting@redhat.com  2006-08-17 13:13 EST -----
--
> Can you attach all the anaconda logs?
> -- 

Is this comment for IBM? do you still need it? Thanks. 

Comment 24 Bill Nottingham 2006-08-18 14:58:48 UTC
No, we've got what we need.

Comment 27 IBM Bug Proxy 2006-09-05 13:51:39 UTC
----- Additional Comments From chavez@us.ibm.com (prefers email at lnx1138@us.ibm.com)  2006-09-05 09:45 EDT -------
Beta1 is now available. Please verify and close. 

Comment 28 IBM Bug Proxy 2006-09-08 15:05:54 UTC
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED
             Impact|------                      |Installability




------- Additional Comments From yongwenw@us.ibm.com  2006-09-08 11:02 EDT -------
In the few partitions I have installed so far, this problem seems to be fixed. 
I will close the bug. Thanks. 


Note You need to log in before you can comment on or make changes to this bug.