Bug 195953 - unable to print
unable to print
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 16:59 EDT by John Poelstra
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 08:35:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Poelstra 2006-06-19 16:59:10 EDT
Description of problem:
Unable to print on FC5 with the current version of cups (cups-1.2.1-1.7) on an
x86_64 box.  Tried to update to latest development version, but it fails with a
dependency error on kde.


Version-Release number of selected component (if applicable):
cups-1.2.1-1.7

How reproducible:
Every time

Steps to Reproduce:
1. yum --enablerepo=development update cups
2.
3.

  
Actual results:
 yum --enablerepo=development update cups
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
development                                                          [1/5]
core                                                                 [2/5]
updates                                                              [3/5]
freshrpms                                                            [4/5]
extras                                                               [5/5]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package cups.x86_64 1:1.2.1-13 set to be updated
--> Running transaction check
--> Processing Dependency: libgnutls.so.13()(64bit) for package: cups
--> Processing Dependency: libgnutls.so.13(GNUTLS_1_3)(64bit) for package: cups
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gnutls.x86_64 0:1.4.0-1 set to be updated
---> Package kdelibs.x86_64 6:3.5.3-4 set to be updated
--> Running transaction check
--> Processing Dependency: libgnutls.so.12()(64bit) for package: cups-libs
--> Processing Dependency: qt >= 1:3.3.6 for package: kdelibs
--> Processing Dependency: arts >= 8:1.5.3 for package: kdelibs
--> Processing Dependency: libgnutls.so.12()(64bit) for package:
evolution-data-server
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Processing Dependency: libgnutls.so.12(GNUTLS_1_2)(64bit) for package: libsoup
--> Processing Dependency: libgnutls.so.12()(64bit) for package: rhythmbox
--> Processing Dependency: libgnutls.so.12(GNUTLS_1_2)(64bit) for package: cups-libs
--> Processing Dependency: libgnutls.so.12()(64bit) for package: libsoup
--> Processing Dependency: libgnutls.so.12()(64bit) for package: evolution-webcal
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package rhythmbox.x86_64 0:0.9.4.1-8 set to be updated
---> Package arts.x86_64 8:1.5.3-1 set to be updated
---> Package evolution-webcal.x86_64 0:2.7.1-4 set to be updated
---> Package cups-libs.x86_64 1:1.2.1-13 set to be updated
---> Package libsoup.x86_64 0:2.2.94-3 set to be updated
---> Package evolution-data-server.x86_64 0:1.7.3-2 set to be updated
---> Package qt.x86_64 1:3.3.6-7 set to be updated
--> Running transaction check
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: qt
--> Processing Dependency: libpng12.so.0(PNG12_0)(64bit) for package: cups-libs
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Processing Dependency: libnotify.so.1()(64bit) for package: rhythmbox
--> Processing Dependency: libecal-1.2.so.6()(64bit) for package: gnome-panel
--> Processing Dependency: libnautilus-burn.so.4()(64bit) for package: rhythmbox
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libnotify.x86_64 0:0.4.0-1 set to be updated
---> Package libpng.x86_64 2:1.2.10-5 set to be updated
---> Package gnome-panel.x86_64 0:2.14.2-4 set to be updated
---> Package nautilus-cd-burner.x86_64 0:2.15.3-1 set to be updated
--> Running transaction check
--> Processing Dependency: libnotify.so.0()(64bit) for package: gnome-power-manager
--> Processing Dependency: libnotify.so.0()(64bit) for package: xchat-gnome
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Processing Dependency: libnotify.so.0()(64bit) for package: NetworkManager-gnome
--> Processing Dependency: libnotify.so.0()(64bit) for package: gnome-volume-manager
--> Processing Conflict: gnome-panel conflicts gnome-power-manager < 2.15.3
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: banshee
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: sound-juicer
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: gnome-media
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package gnome-media.x86_64 0:2.14.2-4 set to be updated
---> Package NetworkManager-gnome.x86_64 0:0.7.0-0.cvs20060529.1 set to be updated
---> Package gnome-power-manager.x86_64 0:2.15.3-1 set to be updated
---> Package gnome-volume-manager.x86_64 0:1.5.15-3 set to be updated
---> Package sound-juicer.x86_64 0:2.15.3-2 set to be updated
--> Running transaction check
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: banshee
--> Processing Dependency: libnotify.so.0()(64bit) for package: xchat-gnome
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Processing Dependency: NetworkManager = 0.7.0-0.cvs20060529.1 for package:
NetworkManager-gnome
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package NetworkManager.x86_64 0:0.7.0-0.cvs20060529.1 set to be updated
--> Running transaction check
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: banshee
--> Processing Dependency: libnotify.so.0()(64bit) for package: xchat-gnome
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Processing Dependency: NetworkManager = 0.6.2-2.fc5 for package:
NetworkManager-glib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package NetworkManager-glib.x86_64 0:0.7.0-0.cvs20060529.1 set to be updated
--> Running transaction check
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: banshee
--> Processing Dependency: libnotify.so.0()(64bit) for package: xchat-gnome
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
--> Processing Dependency: libnautilus-burn.so.3()(64bit) for package: banshee
--> Processing Dependency: libnotify.so.0()(64bit) for package: xchat-gnome
--> Processing Conflict: cups conflicts kdelibs < 6:3.5.2-6
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
--> Running transaction check
Error: Missing Dependency: libnotify.so.0()(64bit) is needed by package xchat-gnome
Error: Missing Dependency: libnautilus-burn.so.3()(64bit) is needed by package
banshee
Error: Unable to satisfy dependencies
Error: Package banshee needs libnautilus-burn.so.3()(64bit), this is not available.
Error: Package xchat-gnome needs libnotify.so.0()(64bit), this is not available.
Error: Package cups conflicts with kdelibs < 6:3.5.2-6.


Expected results:
Update to latest package

Additional info:
Comment 1 Tim Waugh 2006-06-20 04:36:41 EDT
No, you cannot (and are not meant to) piece-wise upgrade to experimental rawhide
packages -- in fact, that is a sure way to *break* things, not fix them.

Please explain more about the real problem -- that you can't print with
1.2.1-1.7.  What exactly is the symptom?
Comment 2 John Poelstra 2006-06-20 14:30:20 EDT
If I use lpr from a command line to print a postscript file...

lpr: Unsupported format 'application/octet-stream'!
Comment 3 Tim Waugh 2006-06-20 14:43:16 EDT
What does 'rpm -V cups; rpm -q cups' say?
Comment 4 John Poelstra 2006-06-20 15:12:04 EDT
Copying mime.types into /etc/cups does not solve the problem.

# rpm -V cups; rpm -q cups
S.5....TC c /etc/cups/cupsd.conf
missing   c /etc/cups/mime.types
cups-1.2.1-1.7

# locate mime.types
/etc/mime.types
/etc/tux.mime.types
/etc/cups/mime.types.rpmsave
/usr/share/doc/cups-1.2.1/help/man-mime.types.html
/usr/share/doc/mutt-1.4.2.1/mime.types
/usr/share/man/man5/mime.types.5.gz

# ls /etc/mime*
/etc/mime-magic  /etc/mime-magic.dat  /etc/mime.types

# ls /etc/cups/mime*
/etc/cups/mime.convs  /etc/cups/mime.types  /etc/cups/mime.types.rpmsave
Comment 5 Tim Waugh 2006-06-22 06:58:50 EDT
Baffled.  How exactly did you upgrade to cups-1.2.1-1.7?  Were there any errors?
 It almost looks like you might have had both the i386 and x86_64 versions
installed at one point, and then removed the i386 one or something.

On my x86_64 machine tracking FC5 I didn't see this.  /etc/cups/mime.types is
fine on my system.
Comment 6 John Poelstra 2006-06-22 07:58:06 EDT
# yum update

This is my primary desktop and I don't do any strange stuff on it.  

What is the best way to revert to the previous packages and re-try the upgrade?
Force install GA version of cups?
Comment 7 Tim Waugh 2006-06-22 08:02:31 EDT
Yes.
Comment 8 John Poelstra 2006-06-22 08:33:09 EDT
All is well in the galaxy.

rpm -Uvh --oldpackage to GA version
yum update cups

Printing works again.
Comment 9 Tim Waugh 2006-06-22 08:35:07 EDT
Weird!

Note You need to log in before you can comment on or make changes to this bug.