Bug 195974 - authconfig-gtk does not require needed fonts
authconfig-gtk does not require needed fonts
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libglade2 (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Winship
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-19 21:43 EDT by Ian Pilcher
Modified: 2012-06-20 09:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Pilcher 2006-06-19 21:43:19 EDT
Description of problem:
When authconfig-gtk is installed on a "minimal" RHEL 4 system, up2date does
not pull in the fonts it needs to actually run.

Version-Release number of selected component (if applicable):
authconfig-gtk-4.6.10-rhel4.1

How reproducible:
100%

Steps to Reproduce:
1.  Do minimal RHEL 4 installation
2.  up2date authconfig-gtk
3.  run authconfig-gtk
4.  Observe font-related error message
  
Actual results:
authconfig-gtk bombs out with font-related error message.

Expected results:
Needed fonts should be pulled in by RPM requirments.

Additional info:
Comment 1 Ian Pilcher 2006-06-19 23:35:33 EDT
Here is the exact error message:

[root@guest1 ~]# authconfig-gtk

(authconfig-gtk.py:2487): libglade-WARNING **: Could not load support for
`gnome': libgnome.so: cannot open shared object file: No such file or directory
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual
page and on http://fontconfig.org
[root@guest1 ~]# up2date fontconfig

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching rpm headers...

Name                                    Version        Rel
----------------------------------------------------------


The following packages you requested are already updated:
fontconfig
Comment 2 Tomas Mraz 2006-06-22 08:54:54 EDT
It is really questionable if authconfig-gtk should directly require these fonts.
They should probably be rather required by libglade2 or another package in the
dependency chain.
Comment 3 Jiri Pallich 2012-06-20 09:26:01 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.