Bug 19598 - Unable login as local user root if files+LDAP authentication configured
Unable login as local user root if files+LDAP authentication configured
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: nss_ldap (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 08:17 EDT by Igor
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 21:49:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor 2000-10-23 08:17:16 EDT
/etc/nsswitch.conf:
...
passwd: files ldap
shadow: files ldap
group: files ldap
...

After check "files" exit UNAVAIL instead SUCCESS at login.
After check "files" exit NOTFOUND instead SUCCESS at start mc.
Comment 1 Jakub Jelinek 2000-10-23 11:07:09 EDT
My first suspicion would be nss_ldap module, because all other nss modules
seem to work well.
Comment 2 Nalin Dahyabhai 2000-10-24 14:57:32 EDT
Have you also enabled use of LDAP for authentication?  Are the network
interfaces up?
Comment 3 Igor 2000-10-25 01:55:25 EDT
This happen if LDAP server not enabled. But login must be successful
in any case if I am local user.
Comment 4 Nick Austin 2002-05-01 20:11:59 EDT
I think that this is a dup of bug# 63631 
 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=63631 
 
I think that your problem only occures when the ldap server is offline or 
unavalable.
Comment 5 Igor 2002-05-06 06:49:17 EDT
This bug appear is absent in recent versions of RH.

Bug #63631 is a dup of bug #26449. 
Please pay attention to it. In the bottom of #26449 problem is resolved by me.

Note You need to log in before you can comment on or make changes to this bug.