Bug 195991 - Kontact icons not showing correctly
Kontact icons not showing correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeartwork (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 03:38 EDT by Mike Cohler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-20 09:17:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cohler 2006-06-20 03:38:48 EDT
Description of problem: Under KDE 3.5.3 just released if Kontact is started then
the "Mail- Kontact" icon in the taskbar shows a generic icon with a question
mark, instead of the correct icon. Also in the left hand column with the icons
for Summary, Mail, Contacts, Calendar etc show initially as generic icons with a
question mark as above but after several minutes change to the correct icons.


Version-Release number of selected component (if applicable):kdepim-3.5.3-0.2.fc5


How reproducible:Always


Steps to Reproduce:
1. Start Personal Information Manager
2. Observe effects listed above
3.
  
Actual results: Icons not behaving as they should


Expected results: Icons should show as normal immediately.


Additional info:
Comment 1 Ngo Than 2006-06-20 06:39:22 EDT
i try with your above steps but cannot reproduce this problem.
It works fine with following icon themes: bluecurve and crystal
kontact shows the icons correctly! it's surely not a bug in kdepim.

Which icontheme are you using? Could you please reinstall all the kde packages
from FC5-update and see if it works for you? Thanks

Comment 2 Rex Dieter 2006-06-20 08:33:54 EDT
I'd bet he's using kdeclassic from kdeartwork-icons.  kdeclassic is missing an
Inherits=
in it's theme.index
Comment 3 Mike Cohler 2006-06-20 08:37:48 EDT
Ngo

I am not sure what you by asking to "re-install" all the packages - certainly
all the packages for KDE are up to date on several of my machines via the yum
nightly update -  I was using the Keramik theme and now that I have switched to
Bluecurve or crystal the fonts are horrible and I cannot now get them back to
the way they should be on my setup. (Using the control centre)

I guess it is possible that the files in my home area (.kderc and .kde) may have
stuff in them from before that is not compatible with the new version but this
has never happened after an upgrade to KDE in the past ?  In that case if I
delete them and login again will they be recreated ?  That also means I would
have to reset my desktop up from scratch - and this is a working machine!

Mike
Comment 4 Mike Cohler 2006-06-20 08:38:50 EDT
Yes I was using kde classic Rex !!!   Now how do I get back to the way I was ?

Thanks

Mike
Comment 5 Mike Cohler 2006-06-20 08:41:19 EDT
Sorry I should have said that I was also using kde-classic -  is that index file
that is missing something that I can fix here or does that need a new update rpm?
Comment 6 Rex Dieter 2006-06-20 08:45:36 EDT
Add (near the top, before any [] sections)
Inherits=hicolor
to 
/usr/share/icons/kdeclassic/index.theme

logout/login should do the trick.  Appears to be a kde bug, because the
Freedesktop.org icon spec says that all icon themes should implicitly inherit
from hicolor.
Comment 7 Ngo Than 2006-06-20 09:17:05 EDT
please add the line "Inherits=hicolor" 
to /usr/share/icons/kdeclassic/index.theme, it should fix the problem.

I will ad the fix in next kdebase rebuild. Thanks for your report.
Comment 8 Ngo Than 2006-06-20 09:18:19 EDT
sorry, i mean kdeartwork
Comment 9 Mike Cohler 2006-06-20 09:48:12 EDT
OK Thanks - that has fixed the problem, although I had to pull back copies of
.kde and .fonts.config from my backup disks to get back to where I was without
having to re-configure my desktop settings !

Anyway I look forward to the next update !

Mike

Note You need to log in before you can comment on or make changes to this bug.