Bug 196010 - undefined symbol: png_get_asm_flags
undefined symbol: png_get_asm_flags
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ImageMagick (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
: Reopened
Depends On: 196580
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 07:05 EDT by Ian Chapman
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 6.2.8.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-27 13:29:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Chapman 2006-06-20 07:05:12 EDT
Description of problem:

When building an rpm under rock, it calls convert to reconvert a png file. 
Convert produces the following error: 

convert: symbol lookup error: /usr/lib64/ImageMagick-6.2.8/modules-Q16/coders/
png.so: undefined symbol: png_get_asm_flags


Version-Release number of selected component (if applicable):
6.2.8.0-1

How reproducible:
convert -transparent '#FF00FF' data/gfx/characters/small/player1r.PNG megamario.
png

Steps to Reproduce:
1. convert -transparent '#FF00FF' <png-in> <png-out>
2.
3.
  
Actual results:
Convert exits with a symbol lookup error

Expected results:
Convert should successfully convert the png. It is successful for FC4 and FC5.

Additional info:
Comment 1 Hans de Goede 2006-06-25 05:12:45 EDT
This is caused by a bug in libpng, see bug 196580 .
Comment 2 Ian Chapman 2006-08-01 14:26:12 EDT
Appears fixed since ImageMagick-6.2.8.0-2 (probably due to libpng fix). Closing.
Comment 3 David Nielsen 2006-08-13 04:25:32 EDT
I'm still seeing this using ImageMagick-6.2.8.0-2 on my amd64 setup
Comment 4 Hans de Goede 2006-08-13 17:54:46 EDT
(In reply to comment #3)
> I'm still seeing this using ImageMagick-6.2.8.0-2 on my amd64 setup

Same for me, Matthias Clasen can you please rebuild ImageMagick, that should fix
this, Thanks!
Comment 5 Matthias Clasen 2006-08-27 13:29:52 EDT
Please reopen if there is still an issue with 6.2.8.0-3.fc6
Comment 6 Hans de Goede 2006-08-27 15:21:46 EDT
I can confirm this is fixed now, thanks

Note You need to log in before you can comment on or make changes to this bug.