Bug 196013 - kdelibs: /etc/profile.d/kde.(csh|sh) should be config files
Summary: kdelibs: /etc/profile.d/kde.(csh|sh) should be config files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 178323
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-20 12:02 UTC by Laurent Rineau
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-24 06:46:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Laurent Rineau 2006-06-20 12:02:36 UTC
What is more, /etc/profile.d/kde.sh is not a config file. rpm --verify 
complains if I modify it. I think this should be fixed (but it should be 
another bug report).


-- Additional comment from rdieter@math.unl.edu on 2006-06-20 07:27 EST --
> What is more, /etc/profile.d/kde.sh is not a config file. rpm --verify 
> complains if I modify it. I think this should be fixed (but it should be 
> another bug report).

IMO, it *should* be marked %config, else local modifications will get lost
when/if kdelibs gets upgraded.  You wouldn't want that, would you?

-- Additional comment from rdieter@math.unl.edu on 2006-06-20 07:30 EST --
Personally, I also think the the source'ing of /etc/sysconfig/prelink is
dubious, because it polutes the users' environment space.

Comment 1 Laurent Rineau 2006-06-20 12:05:18 UTC
Add Rex in Cc. The bug cloning process forgot to add him.


Comment 2 Rex Dieter 2006-06-20 12:12:56 UTC
Sorry Laurent, I previously thought you were arguing the opposite of me, that
/etc/profile.d/kde.* should *not* be %config files.  I'm glad we are in
agreement. (:

Comment 3 Ngo Than 2006-06-24 06:46:36 UTC
it's fixed in 3.5.3-5. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.