Bug 196051 - kcalc not included in kdeutils 3.5.3
kcalc not included in kdeutils 3.5.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
5
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 195990 196178 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 13:04 EDT by Jose Pedro Oliveira
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 05:26:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix the kdeutils package missing kcalc (282 bytes, patch)
2006-06-21 01:26 EDT, Daigoro Toyama
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2006-06-20 13:04:25 EDT
Description of problem:
The last update of kdeutils doesn't include kcalc

Version-Release number of selected component (if applicable):
kdeutils-3.5.3-0.1.fc5

How reproducible:
Always

Steps to Reproduce:
1. update to latest version
2. try to run kcalc
  
Additional info:
The previous version (3.5.2) of kdeutuils included kcalc

$ rpm -qpl kdeutils-3.5.2-0.1.fc5.i386.rpm | grep bin/kcalc
/usr/bin/kcalc

$ rpm -qpl kdeutils-3.5.3-0.1.fc5.i386.rpm | grep bin/kcalc
<no output>
Comment 1 Arthur Pemberton 2006-06-20 20:40:33 EDT
Just want to second this bug report. Post update of KDE, `updatedb; locate kcalc
| grep bin` returns nothing. `yum whatprovides kcalc` returns no binary
containing packages.
Comment 2 Alexei Podtelezhnikov 2006-06-21 00:22:54 EDT
FC4 rpm is ok!
kdeutils-3.5.3-0.1.fc4.i386.rpm contains kcalc. 

Yeah, I am skipping FC-odd's...
Comment 3 Daigoro Toyama 2006-06-21 00:31:03 EDT
I noticed the discrepancy too. The same 3.5.3 update on FC4 contains kuickshow
and kcalc, but on FC5.
Comment 4 Daigoro Toyama 2006-06-21 01:26:47 EDT
Created attachment 131245 [details]
Patch to fix the kdeutils package missing kcalc

Found the problem. The spec file  (kdeutils.spec) does not say it requires
gmp-devel, but without it kdeutils does not compile kcalc in. Please see the
attached patch for kdeutils.spec.
Comment 5 Arthur Pemberton 2006-06-21 04:53:26 EDT
Well it looks like kuickshow is missing too. `locate kuickshow` only returns
files in /usr/share (non executeable files). Should I open a sperate bug report
for this?
Comment 6 Ngo Than 2006-06-21 05:26:08 EDT
we are now using new build system which is very strict in terms of BR.
yes, adding the BR on gmp-devel should fix this issue.
I will build new kdeutils in fc5-update today. Thanks for your report.

Arthur: someone has already filled bug #196067 for kuickshow.
Comment 7 Rex Dieter 2006-06-22 15:05:30 EDT
*** Bug 195990 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2006-06-22 15:06:38 EDT
*** Bug 196178 has been marked as a duplicate of this bug. ***
Comment 9 Jose Pedro Oliveira 2006-06-23 05:40:04 EDT
Than,

When can we expect the FC-5 update?

tia,
jpo
Comment 10 Ngo Than 2006-06-23 08:33:15 EDT
it's still in the queue since yesterday. I think it should be available for 
FC5-update today

Note You need to log in before you can comment on or make changes to this bug.