Bug 19607 - g++ -O2 produces bad asm
Summary: g++ -O2 produces bad asm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-23 15:19 UTC by Matt Wilson
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-23 16:04:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.ii file for bad asm case (310.15 KB, text/plain)
2000-10-23 15:19 UTC, Matt Wilson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:132 normal SHIPPED_LIVE Bug fixing update of GCC 2.96 2000-12-19 05:00:00 UTC

Description Matt Wilson 2000-10-23 15:19:33 UTC
[msw@localhost ~/ice]$ g++ -c -o /tmp/foo.o data.ii -fno-for-scope
[msw@localhost ~/ice]$ g++ -c -o /tmp/foo.o data.ii -fno-for-scope -O2
/tmp/cckvtzEW.s: Assembler messages:
/tmp/cckvtzEW.s:22084: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:22539: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:23449: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:23904: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:26808: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:27263: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:28172: Error: immediate operand illegal with absolute jump
/tmp/cckvtzEW.s:28627: Error: immediate operand illegal with absolute jump

bash-2.04$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)
bash-2.04$ rpm -q gcc
gcc-2.96-57
bash-2.04$ rpm -q gcc-c++
gcc-c++-2.96-57

Comment 1 Matt Wilson 2000-10-23 15:19:56 UTC
Created attachment 4559 [details]
.ii file for bad asm case

Comment 2 Jakub Jelinek 2000-10-23 15:36:31 UTC
Are you very sure you have 2.96-57 on that box?
Richard Henderson fixed this (based on your bugreport) on 28th August
(and fixed that fix on 6th September) and the fix has been included in
2.96-57. I can reproduce this with 2.96-55, but not with 2.96-57 nor any
later compiler.

Comment 3 Matt Wilson 2000-10-23 16:04:07 UTC
Oops, yes, seems to be fine in -57


Note You need to log in before you can comment on or make changes to this bug.