Bug 196078 - ypbind init script improvement
ypbind init script improvement
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ypbind (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2006-06-20 16:40 EDT by Brian Long
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0263
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 18:42:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ypbind init script patch (1.01 KB, patch)
2006-06-20 16:40 EDT, Brian Long
no flags Details | Diff

  None (edit)
Description Brian Long 2006-06-20 16:40:23 EDT
Description of problem:
I would like to submit a patch for possible inclusion in a future RHEL release
(i.e. RHEL 5).  This patch implements two things:
1) A new variable NISTIMEOUT may be specified in /etc/sysconfig/network and that
value is used in the for loop "Listening for an NIS domain server" instead of
the for loop being hard-coded to 20.
2) The init script runs "ip -f inet route" and if this is empty (no routeable
interfaces), the script exits with a failure.  This is useful if a laptop has
all interfaces set to be disabled on boot, ypbind should detect zero interfaces
(except lo) are online and exit.  I'm open to suggestions on a better solution,
but I believe Red Hat needs to provide a working solution for laptops in this
situation.  In some cases, you want ypbind chkconfig'd on but you might boot
with zero interfaces (for example, eth0 is set to be enabled on boot, but it's
not plugged in when I boot away from my docking station).

Version-Release number of selected component (if applicable):
ypbind-1.17.2-8

How reproducible:
Always
Comment 1 Brian Long 2006-06-20 16:40:25 EDT
Created attachment 131225 [details]
ypbind init script patch
Comment 2 Brian Long 2006-06-20 16:41:45 EDT
Feel free to disregard #2 and implement just #1 which would be a big improvement
since I could specific NISTIMEOUT=5 in /etc/sysconfig/network and the for loop
would only run 5 times instead of the hard-coded 20 today.
Comment 3 Brian Long 2006-06-20 17:00:29 EDT
Musical chairs with this bug???  :)
Comment 4 Steve Dickson 2006-07-18 09:57:29 EDT
Fixed in ypbind-1.17.2-9 (for RHEL4) 
Fixed in ypbind-1.19-0.2 (for FC6)
Comment 5 Brian Long 2006-07-18 10:44:27 EDT
Thanks Steve.  I do not see this package in the RHEL 4 Beta channel.  Do you
expect to ship it with 4.4 or does it need to be part of 4.5?
Comment 6 Steve Dickson 2006-07-18 13:44:56 EDT
4.5... But in the meantime, you can pull the ypbind-1.19-0.2 package 
from our Rawhide stream (which is soon to be FC6/RHEL5) and use
that one...  
Comment 7 RHEL Product and Program Management 2006-08-18 11:23:39 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 12 Red Hat Bugzilla 2007-05-01 18:42:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0263.html

Note You need to log in before you can comment on or make changes to this bug.