Bug 196088 - version of libtiff on fc4 prints some multi-page faxes incorrectly
version of libtiff on fc4 prints some multi-page faxes incorrectly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libtiff (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-20 17:39 EDT by Tom Cross
Modified: 2013-07-02 23:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.8.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 09:59:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An example multipage fax that tiff2ps-3.7.1 mangles (53.18 KB, image/tiff)
2006-06-20 17:39 EDT, Tom Cross
no flags Details

  None (edit)
Description Tom Cross 2006-06-20 17:39:41 EDT
Description of problem:
version of libtiff on fc4 prints some multi-page faxes incorrectly

Version-Release number of selected component (if applicable):
libtiff-3.7.1-6.fc4.2

How reproducible:
everytime I use /usr/bin/tiff2ps with certain files, it screws it up

Steps to Reproduce:
1.Receive multi-page fax with strange paper sizes
2. tiff2ps -a1 -h 11 -w 8.5 fax000071383.tif | mpage -1 -Pp13
3.
  
Actual results:
Each page after page 1 shows less information.  It looks like the pagination is
way off

Expected results:
Each page of a multipage fax should be readable (considering it's a fax)

Additional info:
I replaced libtiff-3.7.1-6.fc4.2 with libtiff-3.7.4-7 from a recent fc5 update
and tiff2ps now prints the multipage fax correctly.
Comment 1 Tom Cross 2006-06-20 17:39:41 EDT
Created attachment 131231 [details]
An example multipage fax that tiff2ps-3.7.1 mangles
Comment 2 Tom Cross 2006-10-24 09:25:49 EDT
This has been fixed with a later version of fedora core.  Please close.
Comment 3 Tom Lane 2006-10-24 09:59:16 EDT
OK, thanks for mentioning that (I just took over libtiff package and didn't know
this was already fixed).

Note You need to log in before you can comment on or make changes to this bug.