Bug 19613 - cc1plus ICE: Internal compiler error in expand_expr, at
cc1plus ICE: Internal compiler error in expand_expr, at
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 11:28 EDT by Matt Wilson
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 07:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.ii file (484.98 KB, text/plain)
2000-10-23 11:28 EDT, Matt Wilson
no flags Details

  None (edit)
Description Matt Wilson 2000-10-23 11:28:16 EDT
bash-2.04$ gcc -o /tmp/foo propacc.ii 
....
/usr/src/oo/oo_605_src/basic/source/classes/propacc.cxx:381: syntax error
before `{'
/usr/src/oo/oo_605_src/basic/source/classes/propacc.cxx: In function `void
RTL_Impl_CreatePropertySet 
(StarBASIC *, SbxArray &, unsigned char)':
/usr/src/oo/oo_605_src/basic/source/classes/propacc.cxx:396: Internal
compiler error in expand_expr, at 
expr.c:5992
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

bash-2.04$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)
bash-2.04$ rpm -q gcc
gcc-2.96-57
bash-2.04$ rpm -q gcc-c++
gcc-c++-2.96-57
Comment 1 Matt Wilson 2000-10-23 11:28:41 EDT
Created attachment 4563 [details]
.ii file
Comment 2 Jakub Jelinek 2000-12-20 07:14:11 EST
Fixed in gcc-c++-2.96-69

Note You need to log in before you can comment on or make changes to this bug.