Bug 196135 - selinux eats squid
selinux eats squid
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 09:06 EDT by Chris Ricker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 10:11:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2006-06-21 09:06:44 EDT
Upgraded a working FC5 to FC6 test1, and now squid won't start:


Jun 21 09:06:15 fc5test squid[1522]: Exiting due to repeated, frequent failures
Jun 21 09:12:16 fc5test squid[1580]: Squid Parent: child process 1582 started
Jun 21 09:12:16 fc5test kernel: audit(1150895536.859:14): avc:  denied  {
name_bind } for  pid=1582 comm="squid" src=3130
scontext=root:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
Jun 21 09:12:16 fc5test (squid): Cannot open ICP Port
Jun 21 09:12:16 fc5test squid[1580]: Squid Parent: child process 1582 exited due
to signal 6
Jun 21 09:12:19 fc5test squid[1580]: Squid Parent: child process 1589 started
Jun 21 09:12:20 fc5test kernel: audit(1150895540.175:15): avc:  denied  {
name_bind } for  pid=1589 comm="squid" src=3130
scontext=root:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
Jun 21 09:12:20 fc5test (squid): Cannot open ICP Port
Jun 21 09:12:20 fc5test squid[1580]: Squid Parent: child process 1589 exited due
to signal 6
Jun 21 09:12:23 fc5test squid[1580]: Squid Parent: child process 1595 started
Jun 21 09:12:23 fc5test kernel: audit(1150895543.495:16): avc:  denied  {
name_bind } for  pid=1595 comm="squid" src=3130
scontext=root:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
Jun 21 09:12:23 fc5test (squid): Cannot open ICP Port
Jun 21 09:12:23 fc5test squid[1580]: Squid Parent: child process 1595 exited due
to signal 6
Jun 21 09:12:26 fc5test squid[1580]: Squid Parent: child process 1601 started
Jun 21 09:12:26 fc5test kernel: audit(1150895546.812:17): avc:  denied  {
name_bind } for  pid=1601 comm="squid" src=3130
scontext=root:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
Jun 21 09:12:26 fc5test (squid): Cannot open ICP Port
Jun 21 09:12:26 fc5test squid[1580]: Squid Parent: child process 1601 exited due
to signal 6
Jun 21 09:12:29 fc5test squid[1580]: Squid Parent: child process 1608 started
Jun 21 09:12:30 fc5test kernel: audit(1150895550.128:18): avc:  denied  {
name_bind } for  pid=1608 comm="squid" src=3130
scontext=root:system_r:squid_t:s0
tcontext=system_u:object_r:http_cache_port_t:s0 tclass=udp_socket
Jun 21 09:12:30 fc5test (squid): Cannot open ICP Port
Jun 21 09:12:30 fc5test squid[1580]: Squid Parent: child process 1608 exited due
to signal 6
Jun 21 09:12:30 fc5test squid[1580]: Exiting due to repeated, frequent failures
Comment 1 Daniel Walsh 2006-06-21 10:11:17 EDT
Not sure why squid was working in FC5, since it was not allowed to listen on the
udp port their either.

Fixed in selinux-policy-2.2.48-1

Note You need to log in before you can comment on or make changes to this bug.