Bug 196155 - installation via serial console hangs on Xserve G5 headless node
installation via serial console hangs on Xserve G5 headless node
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
bzcl34nup
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 12:33 EDT by Toni Harbaugh-Blackford
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of attempt to boot FC6 test1 resque cd from Xserve serial console (4.94 KB, text/plain)
2006-06-21 14:51 EDT, Toni Harbaugh-Blackford
no flags Details

  None (edit)
Description Toni Harbaugh-Blackford 2006-06-21 12:33:13 EDT
Description of problem:

Attempting to install FC5 via serial console on an Xserve G5 cluster node
(completely headless) from external Firewire drive hangs shortly after kernel
is loaded

Version-Release number of selected component (if applicable):

FC5 installation cd 1

How reproducible:

Always

Steps to Reproduce:
1.put cd in external firewire drive
2.reboot xserve to open firmware
3.boot installation from external firewire
  
Actual results:

Hangs shortly after the smp_core99_probe line:

  PID hash table entries: 4096 (order: 12, 131072 bytes)
  time_init: decrementer frequency = 33.333333 MHz
  time_init: processor frequency   = 2000.000000 MHz
  smp_core99_probe
  smp_core99_kick_cpu
  smp_core99_kick_cpu done
  core99_setup_cpu 0 done
  Linux ppc64
  
  #1 SMP Tue Mar 14 15:57:06 EST 2006


Expected results:


Additional info:
Comment 1 Toni Harbaugh-Blackford 2006-06-21 14:51:17 EDT
Created attachment 131313 [details]
log of attempt to boot FC6 test1 resque cd from Xserve serial console
Comment 2 Toni Harbaugh-Blackford 2006-06-21 15:03:08 EDT
I tried several flags to the boot command to see if I could get the
serial console install to work with FC6 test1 also.  But nothing worked.

Comment 3 Dave Jones 2006-10-16 14:25:30 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Jon Stanley 2008-01-19 23:39:52 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.
Comment 5 Toni Harbaugh-Blackford 2008-01-20 07:06:54 EST
I never received any email from comment 3 above, so I was unaware that the
bug was in a NEEDINFO state.  I only received email for comment 4 showing
the close.

I am reopening the bug, and will test with rawhide.  2.6.24 has changed
the device that zilog serial controller uses.  This eliminates the need for
a special workaround for zilog.

Comment 6 Jon Stanley 2008-01-20 10:50:26 EST
I'll put this back in NEEDINFO until you can test with rawhide.  Also, beware
that F9 Alpha is just around the corner, so you may want to test with that
(there have been some issues the last few days with rawhide actually being
installable - not sure on the status of that, I think it's resolved except for
maybe some firstboot weirdness)
Comment 7 Jon Stanley 2008-03-09 01:06:04 EST
Reporter, could you please reply to the previous question? If you won't reply in
one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.
Comment 8 Bug Zapper 2008-04-03 23:07:55 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Bug Zapper 2008-05-06 12:01:39 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.