Bug 196184 - Various kernel dependencies are out of date.
Various kernel dependencies are out of date.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnbd-kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Feist
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-21 15:46 EDT by Mr. Mizzen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 12:35:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mr. Mizzen 2006-06-21 15:46:18 EDT
Description of problem:
Various kernel dependencies are out of date.

Version-Release number of selected component (if applicable):
kernel 2.6.16-1.2133_FC5
gnbd-kernel - 2.6.15-5.FC5.28.i686 
gnbd-kernel-xen0 - 2.6.15-5.FC5.28.i686
gnbd-kernel-xenU - 2.6.15-5.FC5.28.i686
gnbd-kernel-smp - 2.6.15-5.FC5.28.i686
cman-kernel - 2.6.15.1-0.FC5.21.i686
cman-kernel-xen0 - 2.6.15.1-0.FC5.21.i686
cman-kernel-xenU - 2.6.15.1-0.FC5.21.i686
cman-kernel-smp - 2.6.15.1-0.FC5.21.i686
GFS-kernel - 2.6.15.1-5.FC5.22.i686
GFS-kernel-xen0 - 2.6.15.1-5.FC5.22.i686
GFS-kernel-xenU - 2.6.15.1-5.FC5.22.i686
GFS-kernel-smp - 2.6.15.1-5.FC5.22.i686
dlm-kernel - 2.6.15.1-0.FC5.19.i686
dlm-kernel-xenU - 2.6.15.1-0.FC5.19.i686
dlm-kernel-smp - 2.6.15.1-0.FC5.19.i686
dlm-kernel-xen0 - 2.6.15.1-0.FC5.19.i686


How reproducible:
Very


Steps to Reproduce:
When building updated FC5 ISOs, I do a dependency check of all files
as the script excerpt shows.

At the moment, the kernel is 2.6.16-1.2133_FC5 and this is where the problem begins.
As the output below shows, several rpm are calling for kernel 2.6.16-1.2122_FC5.
As I build a new iso, those are gone as we are now on 1.2133.


###############################################
# Check for missing dependencies in repo
cat > $FCBASE/yum.conf.temp << EOF 
[main]

[kh-temp]
name=kh-temp
baseurl=file://$FCBASE/$arch/
enabled=0
gpgcheck=0
EOF

echo "`date` - Checking the repo for missing dependencies ..."
repoclosure -c $FCBASE/yum.conf.temp -r kh-temp
##################################################

  
Actual results:
Wed Jun 21 20:34:42 CEST 2006 - Checking the repo for missing dependencies ...
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   kh-temp
Num Packages in Repos: 2265
package: gnbd-kernel-xen0 - 2.6.15-5.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.16-1.2122_FC5
package: cman-kernel - 2.6.15.1-0.FC5.21.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5
package: GFS-kernel-xen0 - 2.6.15.1-5.FC5.22.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.16-1.2122_FC5
package: GFS-kernel-xenU - 2.6.15.1-5.FC5.22.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5xenU
package: gnbd-kernel - 2.6.15-5.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5
package: gnbd-kernel-xenU - 2.6.15-5.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5xenU
package: GFS-kernel-smp - 2.6.15.1-5.FC5.22.i686 from kh-temp
  unresolved deps:
     kernel-smp = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5smp
package: cman-kernel-xen0 - 2.6.15.1-0.FC5.21.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.16-1.2122_FC5
package: dlm-kernel-xenU - 2.6.15.1-0.FC5.19.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5xenU
package: GFS-kernel - 2.6.15.1-5.FC5.22.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5
package: cman-kernel-smp - 2.6.15.1-0.FC5.21.i686 from kh-temp
  unresolved deps:
     kernel-smp = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5smp
package: dlm-kernel-smp - 2.6.15.1-0.FC5.19.i686 from kh-temp
  unresolved deps:
     kernel-smp = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5smp
package: cman-kernel-xenU - 2.6.15.1-0.FC5.21.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5xenU
package: gnbd-kernel-smp - 2.6.15-5.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel-smp = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5smp
package: dlm-kernel-xen0 - 2.6.15.1-0.FC5.19.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.16-1.2122_FC5
package: dlm-kernel - 2.6.15.1-0.FC5.19.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.16-1.2122_FC5
     /lib/modules/2.6.16-1.2122_FC5

Expected results:
No dep errors

Additional info:
Comment 1 Mr. Mizzen 2006-06-24 11:54:16 EDT
As of the new Kernel release 2.6.17-

The following additional dependencies can not be resolved when building updated
FC5 iso files.

##############################################################
Sat Jun 24 16:40:10 CEST 2006 - Checking the repo for missing dependencies ...
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   kh-temp
Num Packages in Repos: 2185
package: dlm - 1.0.0-9.FC5.1.i386 from kh-temp
  unresolved deps:
     dlm-kernel-modules >= 0:2.6.11
package: gnbd - 1.0.2-0.2.1.i386 from kh-temp
  unresolved deps:
     gnbd-kernel-modules >= 0:2.6.11
package: cman - 1.0.5-0.FC5.1.i386 from kh-temp
  unresolved deps:
     cman-kernel-modules >= 0:2.6.11
###############################################################
Comment 2 Dave Jones 2006-06-26 10:39:15 EDT
all these packages need rebuilding. 
Comment 3 Chris Feist 2006-07-10 16:59:42 EDT
All of the GFS/CS -kernel packages have been rebuilt for the latest FC5 kernel
(2.6.17-1.2145_FC5).
Comment 4 Mr. Mizzen 2006-09-18 19:48:32 EDT
Need rebuilding again. At least before the last update to FC5 when FC6 ships.


package: cman-kernel - 2.6.15.1-0.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5
package: dlm-kernel - 2.6.15.1-0.FC5.26.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5
package: dlm-kernel-xen0 - 2.6.15.1-0.FC5.26.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.17-1.2157_FC5
package: GFS-kernel-xenU - 2.6.15.1-5.FC5.33.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5xenU
package: GFS-kernel-smp - 2.6.15.1-5.FC5.33.i686 from kh-temp
  unresolved deps:
     /lib/modules/2.6.17-1.2157_FC5smp
     kernel-smp = 0:2.6.17-1.2157_FC5
package: dlm-kernel-xenU - 2.6.15.1-0.FC5.26.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5xenU
package: gnbd-kernel-xen0 - 2.6.15-5.FC5.36.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.17-1.2157_FC5
package: cman-kernel-xen0 - 2.6.15.1-0.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.17-1.2157_FC5
package: dlm-kernel-smp - 2.6.15.1-0.FC5.26.i686 from kh-temp
  unresolved deps:
     /lib/modules/2.6.17-1.2157_FC5smp
     kernel-smp = 0:2.6.17-1.2157_FC5
package: cman-kernel-xenU - 2.6.15.1-0.FC5.28.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5xenU
package: GFS-kernel-xen0 - 2.6.15.1-5.FC5.33.i686 from kh-temp
  unresolved deps:
     kernel-xen0 = 0:2.6.17-1.2157_FC5
package: cman-kernel-smp - 2.6.15.1-0.FC5.28.i686 from kh-temp
  unresolved deps:
     /lib/modules/2.6.17-1.2157_FC5smp
     kernel-smp = 0:2.6.17-1.2157_FC5
package: gnbd-kernel-xenU - 2.6.15-5.FC5.36.i686 from kh-temp
  unresolved deps:
     kernel-xenU = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5xenU
package: GFS-kernel - 2.6.15.1-5.FC5.33.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5
package: gnbd-kernel - 2.6.15-5.FC5.36.i686 from kh-temp
  unresolved deps:
     kernel = 0:2.6.17-1.2157_FC5
     /lib/modules/2.6.17-1.2157_FC5
package: gnbd-kernel-smp - 2.6.15-5.FC5.36.i686 from kh-temp
  unresolved deps:
     /lib/modules/2.6.17-1.2157_FC5smp
     kernel-smp = 0:2.6.17-1.2157_FC5
Comment 5 Chris Feist 2007-02-28 12:35:59 EST
Deps should be working properly in FC6 and beyond.

Note You need to log in before you can comment on or make changes to this bug.