Bug 19624 - hangs on running /sbin/loader
hangs on running /sbin/loader
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-23 13:20 EDT by Sean Coates
Modified: 2007-04-18 12:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-21 15:23:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Coates 2000-10-23 13:20:57 EDT
On the Compaq Presario 5000 (model 5WV280, AMD Athlon 900MHz, 128MB RAM, 
brand new workstation) the installation process (whether from boot floppy 
or from CD) hangs at:

running /sbin/loader

No matter which options are specified (text, expert, mem=128M, linux 
updates, etc).  

This is true even if the disk is disconnected; this hang occurs before any 
disk activity, partitioning, etc.
Comment 1 Need Real Name 2000-10-24 05:07:50 EDT
same for me, using Toshiba 4000 CDT,  4.6 Gb hardisk, 64 MB memory
Comment 2 Need Real Name 2000-10-24 12:16:56 EDT
I, too, have had this problem.

My system is a dual-boot Dell 300MHz Pentium II with 384MB of RAM.  Video card 
is a Matrox Millenium II AGP card.

I have 2 3D-accelerator (sp?) cards running in parallel, an ethernet card, and 
an ISA card that provides me with an additional serial port.

On one disk, I have Windows 98 installed, and on the other, I have Red Hat 6.2

Interestingly, cfdisk complains about my /dev/hda drive (the Windows drive) and 
I have removed it from /etc/fstab and put it in the /etc/auto.misc file.  The 
error that I get is that "Partition ends after end-of-disk"

/home is automounted via NFS to another computer on my network

The Windows drive is 8.4GB and the linux drive is 5.1GB
/boot is the first partition and takes about 16 MB of space
/usr is next and takes about 3.5 GB of space
swap is next and takes about 500 MB of space
/var is last and takes about 1.1 GB of space
Comment 3 Michael Fulbright 2000-10-30 15:24:05 EST
Could you try running the installer with the 'nousb' option and see if it helps?
Comment 4 Need Real Name 2000-11-13 11:35:11 EST
I have experienced the same problem when booting from CD-ROM or floppy on a 
Compaq 5000 series computer, AMD Duron 700, 64 MB, NVidia TNT2, USB keyboard. 

I was able to install another manufacturer's Linux distribution.
Comment 5 Need Real Name 2000-11-14 10:36:42 EST
Using the "nousb" option I was able to sucessfully install 7.0.
I have the same problem when booting the system, but the "nousb" option solves 
that problem as well.

Thanks
Comment 6 Michael Fulbright 2000-11-15 11:32:41 EST
We have found that the Linux kernel has problems with some USB controllers.

It would be helpful to us to have more information on your USB controller. I am
reassigning this bug to someone who knows more about this issue.
Comment 7 Trond Eivind Glomsrxd 2000-11-15 11:47:10 EST
What does "lspci -v" show?
Comment 8 Need Real Name 2000-11-19 11:02:54 EST
Here's what I got from lspci -v

00:00.0 Host bridge: VIA Technologies, Inc. VT82C691 [Apollo PRO] (rev 03)
	Flags: bus master, medium devsel, latency 0
	Memory at 50000000 (32-bit, prefetchable)
	Capabilities: [a0] AGP version 2.0
	Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc.: Unknown device 8305 (prog-if 00 
[Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	Memory behind bridge: 40000000-40ffffff
	Prefetchable memory behind bridge: 42000000-43ffffff
	Capabilities: [80] Power Management version 2

00:04.0 Modem: PCTel Inc HSP MicroModem 56 (rev 02) (prog-if 01 [Hayes/16450])
	Subsystem: PCTel Inc: Unknown device 0001
	Flags: medium devsel, IRQ 10
	I/O ports at 1800
	Capabilities: [40] Power Management version 2

00:05.0 Ethernet controller: Bridgecom, Inc: Unknown device 0985 (rev 11)
	Subsystem: Bridgecom, Inc: Unknown device 0574
	Flags: bus master, medium devsel, latency 66, IRQ 5
	I/O ports at 1000
	Memory at 41000000 (32-bit, non-prefetchable)
	Capabilities: [c0] Power Management version 2

00:14.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super] (rev 22)
	Flags: bus master, stepping, medium devsel, latency 0

00:14.1 IDE interface: VIA Technologies, Inc. VT82C586 IDE [Apollo] (rev 10) 
(prog-if 8a [Master SecP PriP])
	Flags: bus master, medium devsel, latency 64
	I/O ports at 1880
	Capabilities: [c0] Power Management version 2

00:14.2 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10) (prog-if 
00 [UHCI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 66, IRQ 11
	I/O ports at 1840
	Capabilities: [80] Power Management version 2

00:14.3 USB Controller: VIA Technologies, Inc. VT82C586B USB (rev 10) (prog-if 
00 [UHCI])
	Subsystem: Unknown device 0925:1234
	Flags: bus master, medium devsel, latency 66, IRQ 11
	I/O ports at 1860
	Capabilities: [80] Power Management version 2

00:14.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 30)
	Flags: medium devsel
	Capabilities: [68] Power Management version 2

00:14.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 [Apollo 
Super AC97/Audio] (rev 20)
	Subsystem: Compaq Computer Corporation: Unknown device 003d
	Flags: medium devsel, IRQ 10
	I/O ports at 1400
	I/O ports at 1890
	I/O ports at 1894
	Capabilities: [c0] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation Vanta [NV6] (rev 15) 
(prog-if 00 [VGA])
	Subsystem: nVidia Corporation: Unknown device 001c
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 3
	Memory at 40000000 (32-bit, non-prefetchable)
	Memory at 42000000 (32-bit, prefetchable)
	Capabilities: [60] Power Management version 1
	Capabilities: [44] AGP version 2.0

Comment 9 Trond Eivind Glomsrxd 2000-11-20 14:37:26 EST
What's your /etc/conf.modules?
Comment 10 Need Real Name 2000-11-21 21:55:01 EST
Couldn't find conf.modules.  I assume that you meant modules.conf 
(lesdyxic? :)

Here it is:

alias parport_lowlevel parport_pc 
alias usb-controller usb-uhci 
alias eth0 tulip 

Comment 11 Trond Eivind Glomsrxd 2000-11-22 10:08:32 EST
The filename changed :)

Can you try substituting usb-uhci for uhci, and see if that helps? (booting
without the "nousb" argument)
Comment 12 Need Real Name 2000-11-22 17:11:35 EST
I assume that you meant replace "alias usb-controller usb-uhci" with 
"alias usb-controller uhci"

I made the change and rebooted without the nousb option.  The system hung 
on "Intializing the USB controller..."
Comment 13 Need Real Name 2001-01-02 20:49:04 EST
What is the time frame for resolving this defect?
Comment 14 ckloiber 2001-02-05 17:29:22 EST
Same problem here: Machine runs 7.0 just fine.

It's an MSI motherboard- "K7T Pro 2" sporting a KT133 North Bridge and a VIA 
82C686B SouthBridge.
Comment 15 Panic 2001-02-07 15:08:47 EST
After some work today,  I don't think ckloiber's problem is the same thing -- I
tracked his issue to the loading of the ide-cd.o module during Fisher
installation (using a network install to check, since the VT's are up at that
point in the network install).  The machine is installing on an HP CD-Writer
Plus 9500 -- anyone else using a CD-R, CD-RW, or DVD drive?
Comment 16 Need Real Name 2001-09-15 03:47:08 EDT
Hi
	I just installed Redhat 7.1 on an IBM Thinkpad i1300. Used the nousb option
both for the install and the subsequent boot. However, the thing hangs at
Checking for new hardware. Do I use something like nokudzu option ?
Comment 17 Lakshmi 2001-11-25 00:56:38 EST
Hi,
I too share the same problem. I have an IBM i1200 series, RH 7.1 hangs at 
Checking for new hardware (or while updating the /etc/fstab). After lot of 
reinventing of the wheel, tried nousb - installation goes about fine. 
Subsequent booting up runs into trouble at the stage mentioned above. Even 
tried the interactive option and disabling kudzu. Even this does not work 
(because "Checking for new hardware" - seems to frustrate any attempt). 

I used to have RH6.1 working without any problems with a 2.4 Kernel. Used to 
have similar problem while compiling kernel with UHCI driver. But worked 
somehow with OHCI.

Would appreciate any help

-Lakshmi
Comment 18 mandrickko 2002-04-12 02:40:49 EDT
I got the same "hangs on running /sbin/loader" problem when I tried to install RH 7.2 on thinkpad i1300.

I am not proceeding the installation with "linux nousb". However, how is the  permanent solution
that allows me to use my usb port?

I suspect my RH 7.2 is still not up-to-date with the proper fix. How could I upgrade or patch my release
to make the RH 7.2 the latest?

Thanks 
Mandrick
Comment 19 Need Real Name 2002-05-09 09:00:59 EDT
"linux nousb" doesn't work when installing Redhat 7.3.  I've been trying for 2
days straight to find the secret code to run the 7.3 installer minus USB, but
have so far had no such luck, still completly locks up when loading the USB
drivers.  Please don't tell me I sat through the 7.3 ISO downloads for nothing.

Thanks in advance, 
Bryce
Comment 20 Pete Zaitcev 2002-05-21 12:08:30 EDT
I see this bug rapidly turns into a catch-all "my USB does
not work" bug. This won't do. If the dillution continues, I'll close this
bug with WONTFIX, because multi-problem bugs cannot be fixed ever.

chhabra@eecs.umich.edu, laks98@yahoo.com, mandrickko@yahoo.com
and any other i1200/i1300 sufferers should attach to bug 50225,
which deals with their issue specifically. Their notes are not
to be considered for this bug lifecycle (19624).

btuttle@nmu.edu, please create a new bug in cathegory "anaconda"
so that Dr. Mike's team deals with "nousb" failure.
Comment 21 Pete Zaitcev 2002-05-21 12:09:44 EDT
Shifted to zaitcev.
Comment 22 Pete Zaitcev 2002-05-21 12:31:07 EDT
Oh my, this is one historic bug! The original requestor
s.coates@themunicenter.com and two first reproducers
ehf@syspart.dk, brian@thepaulsens.com do not appear to
have any USB problems whatsoever. Then, steve@dval.com
came along and hijacked the bug for USB.

Steve - please re-try with 7.3 is file a new bug if it breaks.
Lots of changes happened since 7.0 :)

I think I dealt with everyone. The original bug is stale,
so if the original trio is still interested, let them
say it. Otherwise, I'll close in a week.

Comment 23 Sean Coates 2002-05-21 15:23:19 EDT
The PC I reported the bug did indeed have USB on it, actually.  However said PC 
has since been reloaded with BSD and used for other purposes, so the bug is no 
longer an issue for me.  Heck, it was 19 months ago... I gave up hope for a fix 
long ago.
Comment 24 Pete Zaitcev 2002-06-03 15:03:41 EDT
OK, closing.

I am sure this is not the last time we see IRQs mis-assigned,
un-assigned, etc. Those BIOS people, grrrr. Keep poking your
motherboard vendor, they come up with fixes sometimes.
And file new bugs - the worst may happen is that I'll close
them with WONTFIX or NOTABUG.
Comment 25 Tommy Granlund 2004-09-15 11:01:11 EDT
Thank You! Michael Fulbright you are my angel. "Linux nousb" worked 
perfectly. Now I am litle further with my 64-bit Fedore core 2 
installation.

Tommy Granlund, from the Linus Torvals´s homecountry.
Comment 26 Henry Kroll 2005-11-29 06:25:45 EST
Thanks!  The command, "linux nousb" was necessary to install Fedora Core 4 on a
computer with Nvidia chipset (HP Pavilion a390n) to avoid hang at /sbin/loader.
 Subsequently downloading the Nvidia USB, Audio and Video drivers for linux,
from the Nvidia site, restored full USB functionality.  Even got the onboard dsp
modem to work by installing the latest alk driver (7.1b at this writing) from
http://linmodems.technion.ac.il/packages/ltmodem/kernel-2.6/  Cheers!

Henry, www.thenerdshow.com

Note You need to log in before you can comment on or make changes to this bug.