This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 196276 - Pup fails to initialize
Pup fails to initialize
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 195616 195706 196396 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 08:16 EDT by Bob Agel
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 12:45:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pup fails to initialize after updates (3.88 KB, application/octet-stream)
2006-06-22 08:16 EDT, Bob Agel
no flags Details

  None (edit)
Description Bob Agel 2006-06-22 08:16:11 EDT
Description of problem:After updates 6/22, pup now fails to initialize


Version-Release number of selected component (if applicable):


How reproducible:
Click on pup, no response; in terminal, 'pup' gives error below  - see
attachment for updates at time of failure

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[root@localhost ~]# pup
Traceback (most recent call last):
  File "/usr/sbin/pup", line 29, in ?
    import gtk
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 43, in ?
    from _gtk import *
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined
symbol: gtk_print_settings_get_print_to_file



Expected results:


Additional info:
Comment 1 Bob Agel 2006-06-22 08:16:12 EDT
Created attachment 131349 [details]
pup fails to initialize after updates
Comment 2 Bob Agel 2006-06-22 11:26:28 EDT
Wider problem, apparently.  Just tried 'system-config-printer' and received this
error:

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6, in ?
    import gtk.glade
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 43, in ?
    from _gtk import *
ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/gtk/_gtk.so: undefined
symbol: gtk_print_settings_get_print_to_file
Comment 3 Jeremy Katz 2006-06-22 11:39:15 EDT
The new gtk2 broke pygtk2... working on it.
Comment 4 Jeremy Katz 2006-06-22 12:45:55 EDT
  Fixed in pygtk2-2.9.2-1
Comment 5 Jeremy Katz 2006-06-22 20:05:18 EDT
*** Bug 196396 has been marked as a duplicate of this bug. ***
Comment 6 Paul Dickson 2006-06-23 02:16:17 EDT
Bug #195706 might also be this bug too.
Comment 7 Jeremy Katz 2006-06-23 11:30:56 EDT
*** Bug 195706 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2006-06-23 11:30:58 EDT
*** Bug 195616 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.