Bug 196277 - scriptlet failed
scriptlet failed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: esmtp (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 08:24 EDT by Neal Becker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.1-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 12:12:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2006-06-22 08:24:04 EDT
Description of problem:
Output from esmtp-0.5.1-11.fc5@x86_64:
link /usr/lib/sendmail incorrect for slave mta-sendmail (/usr/lib64/sendmail 
mta-sendmail)
error: %post(esmtp-0.5.1-11.fc5.x86_64) scriptlet failed, exit status 2



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Neal Becker 2006-06-22 08:25:54 EDT
rpm -q --scripts esmtp
ERROR: ld.so: object '/usr/NX/lib/libesddsp.so.0' from LD_PRELOAD cannot be 
preloaded: ignored.
ERROR: ld.so: object '/usr/NX/lib/libesd.so.0' from LD_PRELOAD cannot be 
preloaded: ignored.
ERROR: ld.so: object '/usr/NX/lib/libesddsp.so.0' from LD_PRELOAD cannot be 
preloaded: ignored.
ERROR: ld.so: object '/usr/NX/lib/libesd.so.0' from LD_PRELOAD cannot be 
preloaded: ignored.
postinstall scriptlet (using /bin/sh):
/usr/sbin/alternatives --install /usr/sbin/sendmail mta /usr/bin/esmtp 30 \
        --slave /usr/bin/mailq mta-mailq /usr/bin/esmtp \
        --slave /usr/bin/newaliases mta-newaliases /usr/bin/esmtp \
        --slave /usr/lib64/sendmail mta-sendmail /usr/bin/esmtp \
        --slave /usr/share/man/man1/mailq.1.gz 
mta-mailqman /usr/share/man/man1/esmtp.1.gz \
        --slave /usr/share/man/man1/newaliases.1.gz 
mta-newaliasesman /usr/share/man/man1/esmtp.1.gz \
        --slave /usr/share/man/man8/sendmail.8.gz 
mta-sendmailman /usr/share/man/man1/esmtp.1.gz \
Comment 2 Patrice Dumas 2006-06-22 12:12:03 EDT
Thanks for the report. I have set

        --slave %{_prefix}/lib/sendmail mta-sendmail %{_bindir}/esmtp \

in 0.5.1-12

Note You need to log in before you can comment on or make changes to this bug.