Bug 19628 - checkpc can hang on a printer device
Summary: checkpc can hang on a printer device
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: LPRng   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-23 18:47 UTC by Joe Krahn
Modified: 2007-03-27 03:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 21:38:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Krahn 2000-10-23 18:47:32 UTC
I have set up and sucessfully used a printer through an IR port.
However, checkpc hangs when checking /dev/irlpt1 for
being writeable. Changing options to Checkwrite() to do a
non-blocking open fixes the problem.  There may be other
intermittant devices that will do the same thing.
Here's a diff for the very simple fix:

*** checkpc.c	Mon Oct 23 14:31:37 2000
--- checkpc.c.orig	Mon Oct 23 14:30:46 2000
***************
*** 410,412 ****
  				Printer_DYN, s, Errormsg(errno) );
! 		} else if( (fd = Checkwrite(s,&statb,0,0,1)) < 0 ){
  			WARNMSG( "%s: cannot open lp device '%s' - %s",
--- 410,412 ----
  				Printer_DYN, s, Errormsg(errno) );
! 		} else if( (fd = Checkwrite(s,&statb,0,0,0)) < 0 ){
  			WARNMSG( "%s: cannot open lp device '%s' - %s",

Comment 1 Crutcher Dunnavant 2001-03-12 14:39:03 UTC
investigating.

Comment 2 Crutcher Dunnavant 2001-03-27 21:38:11 UTC
Can you tell me which test this was in?

Comment 3 Crutcher Dunnavant 2001-03-29 16:18:37 UTC
looks like LPRng 3.7.4 already does this.


Note You need to log in before you can comment on or make changes to this bug.