Bug 196321 - Nsf-utils yum update fails - missing dependency librpcsecgss.so.1
Nsf-utils yum update fails - missing dependency librpcsecgss.so.1
Status: CLOSED DUPLICATE of bug 197219
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 11:38 EDT by Bob Agel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-01 10:19:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update (4.40 KB, application/octet-stream)
2006-06-22 15:00 EDT, Bob Agel
no flags Details

  None (edit)
Description Bob Agel 2006-06-22 11:38:28 EDT
Description of problem: yum update nsf-utils fails with:
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steve Dickson 2006-06-22 13:21:33 EDT
This should be fixed in Rawhide... Please
yum update nfs-utils to see if it is...
Comment 2 Bob Agel 2006-06-22 15:00:22 EDT
Created attachment 131374 [details]
yum update
Comment 3 Bob Agel 2006-06-22 15:02:34 EDT
I've attached the latest yum updates, which are inconsistant and the problem
still remains.
Comment 4 Bob Agel 2006-06-23 21:01:06 EDT
another series of updates, but problem remains.   nfs-utils-lib.i386 0:1.0.8-5
still fails on dependency for librpcsecgss.so.1  No luck finding this lib in or
out of FC.   
Comment 5 Steve Dickson 2006-06-24 08:29:10 EDT
update nfs-utils to nfs-utils-1.0.8-2
Comment 6 Bob Agel 2006-06-24 12:12:58 EDT
No joy.  Downloaded nfs-utils-1.0.8-2 to /home and used rpm to install as follows:

[root@localhost bob]# rpm -Uvh *.rpm
error: Failed dependencies:
        librpcsecgss.so.2 is needed by nfs-utils-1.0.8-2.i386
[root@localhost bob]# rpm -Uvh --nodeps *.rpm
Preparing...                ########################################### [100%]
        package nfs-utils-1.0.8.rc4-1 (which is newer than nfs-utils-1.0.8-2) is
already installed
[root@localhost bob]# rpm -e nsf-utils-1.0.8.rc4-1
error: package nsf-utils-1.0.8.rc4-1 is not installed
[root@localhost bob]# rpm -Uvh *.rpm
error: Failed dependencies:
        librpcsecgss.so.2 is needed by nfs-utils-1.0.8-2.i386
[root@localhost bob]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nfs-utils-lib.i386 0:1.0.8-5 set to be updated
--> Running transaction check
--> Processing Dependency: librpcsecgss.so.1 for package: nfs-utils
--> Finished Dependency Resolution
Error: Missing Dependency: librpcsecgss.so.1 is needed by package nfs-utils
Comment 7 Bob Agel 2006-06-24 12:19:48 EDT
Success!  Okay, my error.  
[root@localhost bob]# rpm -qa | grep nfs-utils
nfs-utils-lib-1.0.8-3.1
nfs-utils-1.0.8.rc4-1

So, 
yum remove nfs-utils
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package nfs-utils.i386 0:1.0.8.rc4-1 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 nfs-utils               i386       1.0.8.rc4-1      installed         763 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       1 Package(s)
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Shutting down NFS mountd: [FAILED]
Shutting down NFS daemon: [FAILED]
Shutting down NFS quotas: [FAILED]
Shutting down NFS services:  [  OK  ]
Shutting down RPC idmapd: [  OK  ]
Stopping NFS statd: [  OK  ]
  Removing  : nfs-utils                    ######################### [1/1]

Removed: nfs-utils.i386 0:1.0.8.rc4-1
Complete!

followed by:

rpm -Uvh --nodeps *.rpm
Preparing...                ########################################### [100%]
   1:nfs-utils              ########################################### [100%]
[root@localhost bob]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for nfs-utils-lib to pack into transaction set.
http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/development/i386/os/Fedora/RPMS/nfs-utils-lib-1.0.8-5.i386.rpm:
[Errno 14] HTTP Error 404: Date: Sat, 24 Jun 2006 16:24:07 GMT
Server: Apache/2.0.46 (Red Hat)
Content-Length: 389
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
nfs-utils-lib-1.0.8-5.i38 100% |=========================| 4.9 kB    00:00
---> Package nfs-utils-lib.i386 0:1.0.8-5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 nfs-utils-lib           i386       1.0.8-5          development        54 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)
Total download size: 54 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): nfs-utils-lib-1.0. 100% |=========================|  54 kB    00:05
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : nfs-utils-lib                ######################### [1/2]
  Cleanup   : nfs-utils-lib                ######################### [2/2]

Updated: nfs-utils-lib.i386 0:1.0.8-5
Complete!
[root@localhost bob]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
No Packages marked for Update/Obsoletion

Comment 8 Steve Dickson 2006-07-01 10:19:03 EDT

*** This bug has been marked as a duplicate of 197219 ***

Note You need to log in before you can comment on or make changes to this bug.