Bug 196335 - Azureus does not start (missing classes)
Azureus does not start (missing classes)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anthony Green
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 12:35 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 12:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-06-22 12:35:17 EDT
Description of problem:
azureus fails to start with:

/usr/bin/build-classpath: error: Could not find swt-gtk-3.1.1 Java extension for
this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Exception in thread "main" java.lang.NoClassDefFoundError:
org.gudy.azureus2.ui.swt.Server
   at java.lang.Class.initializeClass(libgcj.so.7)
   at org.gudy.azureus2.ui.swt.Main.<init>(Azureus2.jar.so)
   at org.gudy.azureus2.ui.swt.Main.main(Azureus2.jar.so)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.widgets.Display not
found in
gnu.gcj.runtime.SystemClassLoader{urls=[file:/usr/share/java/jakarta-commons-cli.jar,file:/usr/share/java/log4j.jar,file:/usr/share/java/gtk2.8.jar,file:/usr/share/java/glib0.2.jar,file:/usr/share/azureus/Azureus2.jar],
parent=gnu.gcj.runtime.ExtensionsClassLoader{urls=[], parent=null}}
  at java.net.URLClassLoader.findClass(libgcj.so.7)
  at java.net.lang.ClassLoader.loadClass(libgcj.so.7)
  at java.net.lang.classLoader.loadClass(libgcj.so.7)
  at java.net.lang.Class.initializeClass(libgcj.so.7)
  ...2 more

Version-Release number of selected component (if applicable):
azureus-2.4.0.3-0.20060328cvs_5.fc6

How reproducible:
Always

Steps to Reproduce:
1. start azureus
2.
3.
  
Actual results:
Java failure above

Expected results:
startup

Additional info:
Comment 1 Anthony Green 2006-08-13 12:18:20 EDT
Azureus needed to be ported to newer versions of SWT, etc.  I updated the
rawhide azureus today.  It should show up in the mirrors in a day or so.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.