Bug 196342 - yum update fails on python-abi & gdal-python
yum update fails on python-abi & gdal-python
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-22 13:12 EDT by David Kaplan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-29 16:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2006-06-22 13:12:55 EDT
Description of problem:
For the last week, yum update has failed as follows:

# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/7]
livna                     100% |=========================|  951 B    00:00
jpackage16-fc4                                                       [2/7]
jpackage16-fc4            100% |=========================|  951 B    00:00
macromedia                                                           [3/7]
macromedia                100% |=========================|  951 B    00:00
core                                                                 [4/7]
//var/cache/yum/core/repomd.xml:50: parser error : Opening and ending tag
mismatch: img line 48 and div
</div>
      ^
//var/cache/yum/core/repomd.xml:51: parser error : Opening and ending tag
mismatch: img line 45 and div
    </div>
          ^
//var/cache/yum/core/repomd.xml:73: parser error : Entity 'nbsp' not defined
  <div id="border">&nbsp;</div>
                         ^
//var/cache/yum/core/repomd.xml:79: parser error : Entity 'copy' not defined
    <span class="text">Copyright &copy; 2004 NGI S.p.A. | All rights reserved</s
                                      ^
//var/cache/yum/core/repomd.xml:85: parser error : Opening and ending tag
mismatch: div line 10 and body
</body>
       ^
//var/cache/yum/core/repomd.xml:86: parser error : Opening and ending tag
mismatch: body line 9 and html
</html>
       ^
//var/cache/yum/core/repomd.xml:87: parser error : Premature end of data in tag
html line 3

^
core                      100% |=========================| 2.7 kB    00:00
http://fedora.ngi.it/5/i386/os/repodata/repomd.xml: [Errno -1] Error importing
repomd.xml for core: Error: could not parse file //var/cache/yum/core/repomd.xml
Trying other mirror.
core                      100% |=========================| 1.1 kB    00:00
updates                                                              [5/7]
updates                   100% |=========================|  951 B    00:00
jpackage16-generic                                                   [6/7]
jpackage16-generic        100% |=========================|  951 B    00:00
extras                                                               [7/7]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 459 kB    00:01
updates   : ################################################## 1346/1346
Added 27 new packages, deleted 33 old in 6.95 seconds
primary.xml.gz            100% |=========================| 366 kB    00:01
jpackage16: ################################################## 1597/1597
Added 0 new packages, deleted 0 old in 2.39 seconds
primary.xml.gz            100% |=========================| 1.0 MB    00:24
extras    : ################################################## 3909/3909
Added 76 new packages, deleted 26 old in 15.68 seconds
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package selinux-policy-strict.noarch 0:2.2.43-4.fc5 set to be updated
---> Package tkinter.i386 0:2.4.3-4.FC5 set to be updated
---> Downloading header for gdm to pack into transaction set.
gdm-2.14.9-1.i386.rpm     100% |=========================|  67 kB    00:00
---> Package gdm.i386 1:2.14.9-1 set to be updated
---> Package perl.i386 4:5.8.8-5 set to be updated
---> Package gtk2.i386 0:2.8.19-2 set to be updated
---> Package gnome-themes.noarch 0:2.14.2-1.fc5.1 set to be updated
---> Package rhgb.i386 0:0.16.3-1.fc5.1 set to be updated
---> Package freenx.i386 0:0.5.0-0.5.test7.fc5 set to be updated
---> Package libselinux-devel.i386 0:1.30.3-3.fc5 set to be updated
---> Downloading header for openct to pack into transaction set.
openct-0.6.8-1.fc5.i386.r 100% |=========================|  12 kB    00:00
---> Package openct.i386 0:0.6.8-1.fc5 set to be updated
---> Package libselinux.i386 0:1.30.3-3.fc5 set to be updated
---> Package xterm.i386 0:213-1.FC5 set to be updated
---> Package python.i386 0:2.4.3-4.FC5 set to be updated
---> Package python-devel.i386 0:2.4.3-4.FC5 set to be updated
---> Package libselinux-python.i386 0:1.30.3-3.fc5 set to be updated
---> Package tcl.i386 0:8.4.13-1.1 set to be updated
---> Package cups.i386 1:1.2.1-1.7 set to be updated
---> Package cups-libs.i386 1:1.2.1-1.7 set to be updated
---> Package qt.i386 1:3.3.6-0.1.fc5 set to be updated
---> Package nx.i386 0:1.5.0-10.fc5 set to be updated
---> Package nss.i386 0:3.11.1-1.fc5 set to be updated
---> Package policycoreutils.i386 0:1.30.10-2.fc5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.2.43-4.fc5 set to be updated
---> Package desktop-backgrounds-basic.noarch 0:2.0-31.fc5.1 set to be updated
---> Package selinux-policy.noarch 0:2.2.43-4.fc5 set to be updated
---> Package rsync.i386 0:2.6.8-1.FC5.1 set to be updated
---> Package coreutils.i386 0:5.96-1.2 set to be updated
---> Package cups-devel.i386 1:1.2.1-1.7 set to be updated
---> Package firefox.i386 0:1.5.0.4-1.2.fc5 set to be updated
---> Package arts.i386 8:1.5.3-0.1.fc5 set to be updated
---> Package gnome-session.i386 0:2.14.2-1.fc5.1 set to be updated
---> Package libsepol.i386 0:1.12.17-1.fc5 set to be updated
---> Package autofs.i386 1:4.1.4-27 set to be updated
---> Package kdelibs.i386 6:3.5.3-0.2.fc5 set to be updated
---> Package avahi.i386 0:0.6.10-1.FC5 set to be updated
---> Package smartmontools.i386 1:5.36-fc5.1 set to be updated
---> Package dhclient.i386 11:3.0.3-28 set to be updated
---> Package tk.i386 0:8.4.13-1.1 set to be updated
---> Package shadow-utils.i386 2:4.0.14-9.FC5 set to be updated
---> Package gtk2-devel.i386 0:2.8.19-2 set to be updated
---> Package avahi-glib.i386 0:0.6.10-1.FC5 set to be updated
---> Package qt-devel.i386 1:3.3.6-0.1.fc5 set to be updated
---> Package gnome-screensaver.i386 0:2.14.2-1.fc5.1 set to be updated
---> Package fedora-logos.noarch 0:1.1.42-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: python-abi = 2.3 for package: gdal-python
--> Finished Dependency Resolution
Error: Missing Dependency: python-abi = 2.3 is needed by package gdal-python
Comment 1 Mihai Ibanescu 2006-06-29 16:01:11 EDT
You are trying to install a package that requires python 2.3 on Fedora Core 5,
which has python 2.4.3. The dependency error is correct, you should not do that :-)

You may want to check the version of gdal-python in that repository, it seems wrong.

Note You need to log in before you can comment on or make changes to this bug.