Bug 196445 - Could not initialize SDL: No available video device.
Summary: Could not initialize SDL: No available video device.
Status: CLOSED DUPLICATE of bug 195398
Alias: None
Product: Fedora
Classification: Fedora
Component: SDL   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Konstantin Ryabitsev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-23 12:20 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 09:07:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Dumas 2006-06-23 12:20:35 UTC
Description of problem:

I get the following when running uqm on devel:
[dumas@localhost ~]$ uqm
The Ur-Quan Masters v0.5.0 (compiled Feb 15 2006 15:07:41)
This software comes with ABSOLUTELY NO WARRANTY;
for details see the included 'COPYING' file.

Initializing base SDL functionality.
Using SDL version 1.2.10 (compiled with 1.2.9)
Could not initialize SDL: No available video device.

Maybe this is caused by the difference in SDL versions uqm is 
built against. Even though it is not the reason I guess it should 
be rebuilt.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Konstantin Ryabitsev 2006-06-24 03:39:09 UTC
I've rebuilt it with 1.2.10, but the result is the same:

Initializing base SDL functionality.
Using SDL version 1.2.10 (compiled with 1.2.10)
Could not initialize SDL: No available video device.

I'm pretty sure at this point that the bug is in SDL, not in uqm. Will set
accordingly.

Comment 2 Paul Dickson 2006-06-25 08:19:54 UTC
I get this problem with SDL-1.2.10-2.i386.rpm and stellarium.

If I revert back to earlier versions of SDL, including SDL-1.2.10-1.i386.rpm and
1.2.9, stellarium runs OK.

The last few lines of strace:

open("/dev/fb0", O_RDWR)                = -1 ENOENT (No such file or directory)
open("/dev/fb/0", O_RDWR)               = -1 ENOENT (No such file or directory)
write(2, "Error: unable to open SDL with a"..., 64Error: unable to open SDL with
audio: No available video device
) = 64
open("/dev/fb0", O_RDWR)                = -1 ENOENT (No such file or directory)
open("/dev/fb/0", O_RDWR)               = -1 ENOENT (No such file or directory)
write(2, "Error: unable to open SDL: No av"..., 53Error: unable to open SDL: No
available video device
) = 53
exit_group(-1)                          = ?
Process 8989 detached
$


Comment 3 Paul Dickson 2006-06-25 08:27:54 UTC
SDL-1.2.10-2 is 25% smaller than SDL-1.2.10-2 (178965 vs 237668).  This is from
a changelog entry which states "added missing (build) requires for GL and GLU".

Did it not build correctly?

Comment 4 Paul Dickson 2006-06-25 08:29:08 UTC
Make the previous comment:
  SDL-1.2.10-2 is 25% smaller than SDL-1.2.10-1 (178965 vs 237668).

Comment 5 Patrice Dumas 2006-06-26 09:07:39 UTC

*** This bug has been marked as a duplicate of 195398 ***


Note You need to log in before you can comment on or make changes to this bug.