Bug 196450 - mTime of semanage.{read,trans}.LOCK always differs
Summary: mTime of semanage.{read,trans}.LOCK always differs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-23 13:31 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.3.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-16 16:05:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2006-06-23 13:31:31 UTC
Description of problem:
$ rpm -qaV selinux-policy-targeted
........C   /etc/selinux/targeted/modules/active
.......T.   /etc/selinux/targeted/modules/semanage.read.LOCK
.......T.   /etc/selinux/targeted/modules/semanage.trans.LOCK
$

SELinux context mismatch is already filed in bug #193488 and #193489. This
bug report is because of differing mTime.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.3.1-1

How reproducible:
rpm -qV selinux-policy-targeted

 
Actual results:
mTime of /etc/selinux/targeted/modules/semanage.{read,trans}.LOCK always differs

Expected results:
The following small change resolves the issue (tested):

--- selinux-policy.spec       2006-06-23 15:10:10.000000000 +0200
+++ selinux-policy.spec.rsc   2006-06-23 15:33:30.000000000 +0200
@@ -112,8 +112,8 @@
 %config(noreplace) %{_sysconfdir}/selinux/%1/setrans.conf \
 %ghost %{_sysconfdir}/selinux/%1/seusers \
 %dir %{_sysconfdir}/selinux/%1/modules \
-%{_sysconfdir}/selinux/%1/modules/semanage.read.LOCK \
-%{_sysconfdir}/selinux/%1/modules/semanage.trans.LOCK \
+%verify(not mtime) %{_sysconfdir}/selinux/%1/modules/semanage.read.LOCK \
+%verify(not mtime) %{_sysconfdir}/selinux/%1/modules/semanage.trans.LOCK \
 %attr(700,root,root) %dir %{_sysconfdir}/selinux/%1/modules/active \
 #%verify(not md5 size mtime) %attr(600,root,root) %config(noreplace) %
{_sysconfdir}/selinux/%1/modules/active/seusers \
 %dir %{_sysconfdir}/selinux/%1/policy/ \

Comment 1 Daniel Walsh 2006-07-11 18:19:17 UTC
Fixed in selinux-policy-2.3.2-2

Comment 2 Robert Scheck 2006-07-16 16:05:26 UTC
Confirmed to work in 2.3.2-4 - thanks, closing now.


Note You need to log in before you can comment on or make changes to this bug.