Bug 196497 - Konqueror: Tools / Open Terminal opens "Root Shell" instead of normal user shell
Konqueror: Tools / Open Terminal opens "Root Shell" instead of normal user shell
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-23 15:20 EDT by Russell East
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 08:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 129711 None None None Never

  None (edit)
Description Russell East 2006-06-23 15:20:07 EDT
Description of problem:

Open Konqueror (as file manager) within regular user account (not root) and not
using "file manager as root".  navigate to any directory.  Press F4 or select
Tools / Open Terminal.  Either way, a "Root shell" opens instead of regular
shell window.   It was all working fine with 3.5.2, and started doing this with
latest updates from Fedora.

Version-Release number of selected component (if applicable):

     KDE 3.5.3-0.2.fc5 Red Hat 

How reproducible:

always

Steps to Reproduce:

as specified above
  
Actual results:

Root Shell opens

Expected results:

regular non-root Shell opening

Additional info:

Have areported it to KDE first, here:
    http://bugs.kde.org/show_bug.cgi?id=129711
Their reaction - they cannot repro, must be Fedora setup.
Comment 1 Ngo Than 2006-06-24 09:50:11 EDT
i cannot reproduce this problem with current KDE-3.5.3 from FC5 update.
It works fine for me. I guess it's surely a bug in your KDE setting!

Could you please try with a fresh new user if the problem still appears?

Thanks

Comment 2 Russell East 2006-06-24 19:57:19 EDT
But, I made no changes to Konqueror setup.   All I did was do a yum update, and
all the recent KDE stuff installed, then this started happening....

How in heck do I change which script or program is being called when I choose
Tools / Open Terminal ?
Comment 3 Ngo Than 2006-06-26 04:28:43 EDT
does this problem appear with a fresh new user ?
Comment 4 Russell East 2006-06-26 08:04:43 EDT
No, the problem does not occur for a fresh new user.  What is concerning me is,
I made no changes to Konqueror settings before, during or fater the recent KDE
update.  How can such a setting just appear out of nowhere?  Or, how do I change
it back?
Comment 5 Ngo Than 2006-06-26 08:53:33 EDT
I don't know why this problem does happen on your machine. But it's surely
a user setting problem.

The quicky fix is to remove $HOME/.kde directory if you don't have many
own settings here.
Comment 6 Russell East 2006-06-26 10:02:03 EDT
Really like to avoid removing .kde if possible.

I found the following within both ~/.kde/share/apps/konqueror/konqueror.rc and
/usr/share/apps/konqueror/konqueror.rc :
  <Menu name="tools" >
   <text>&amp;Tools</text>
   <Action name="open_terminal" />
   <Action name="findfile" />
   <WeakSeparator/>
   <Merge/>
  </Menu>

But I searced all text files within /usr/share/apps and could find no definition
of action "open_terminal".   The nearest I got was
/usr/share/apps/konqueror/servicemenus/konsolehere.desktop .

Am I on the right track, or is there some other place for defining a Konqueror
action?

Comment 7 Ngo Than 2006-06-26 10:44:20 EDT
It looks ok for me. You should probably take a look at your home if the
.config and .local directories exists. If yes, rename both to *.orig
and start KDE again. You should do this change in text console (not in KDE 
session)
Comment 8 Russell East 2006-06-27 12:26:22 EDT
Ok, I renamed .local and .config as you suggested, but it made no difference.

Can you tell me where Tools/OpenTerminal is scripted?  or is it hard-coded into
Konqueror?

Or is there maybe an environment variable that KDE 3.5.3 now uses, that it
didn't within 3.5.2 ?

Note You need to log in before you can comment on or make changes to this bug.