Bug 196542 - missing dependency of libXfont-devel on fontenc-devel
missing dependency of libXfont-devel on fontenc-devel
Status: CLOSED DUPLICATE of bug 185778
Product: Fedora
Classification: Fedora
Component: libXfont (Show other bugs)
5
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-24 05:19 EDT by Dimitri Papadopoulos
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-25 15:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitri Papadopoulos 2006-06-24 05:19:50 EDT
Description of problem:
$ pkg-config --list-all
[...]
Package fontenc was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontenc.pc'
to the PKG_CONFIG_PATH environment variable
Package 'fontenc', required by 'Xfont', not found
$ 
$ cat /usr/lib/pkgconfig/xfont.pc
[...]
Requires.private: fontenc freetype2
$ 
Unless this is a pkg-config bug, libXfont-devel should depend on fontenc-devel.


Version-Release number of selected component (if applicable):
1.0.0-2.2


How reproducible:
Always


Steps to Reproduce:
1. pkg-config --list-all
  

Actual results:
Package fontenc was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontenc.pc'
to the PKG_CONFIG_PATH environment variable
Package 'fontenc', required by 'Xfont', not found


Expected results:
xfont                       Xfont - X font Library
Comment 1 Mike A. Harris 2006-06-25 15:36:42 EDT

*** This bug has been marked as a duplicate of 185778 ***

Note You need to log in before you can comment on or make changes to this bug.